Can't restore leaderboard or rider list on iPad after swiping it away

I thought I’d seen this on the forums before but maybe I’m thinking of the reverse issue (where people on iPads could not swipe away the leaderboard when they wanted to). This is on version 1.45.0 (116914) and iPadOS 16.6.

I was on a group ride 8/16 evening US East time, everything is working as expected. The ride finishes up, some of us stay on the course (Gotham Grind in NYC) and keep riding. I’d picked up the sprint jersey during the ride, but after a while I knew my hour was almost up, so I was curious to see who’d get it next … and I realized that when I came up to the sprint again, there was no leaderboard. Tried to swipe from the left side to restore it and couldn’t, tried to hide the HUD and then show it again and that just restored what I was seeing (rider list on the right, nothing on the left). Finished another lap on the course and couldn’t get the leaderboard up at any point.

What I did notice was that every time I swiped, the action bar popped up (if it was hidden) or hid (if it was visible), so I’m wondering if the check for a tap to show the action bar is overriding the swipe to show the leaderboard, or if it’s just some odd situation with my iPad - I rarely hide the leaderboard and never on purpose, so as far as I can recall it’s the first time it’s happened to me. On previous versions of Zwift I’ve been able to restore the leaderboard, but don’t know how far back that was.

I started up Zwift again just now in Just Watch mode, and I can reproduce the problem with both the leaderboard and the rider list: if I try to swipe them back, instead the action bar pops up, and in fact what seems to happen is that the highlighted icon on the action bar changes in the direction I’m swiping, which again makes me think the swipe is being applied to the action bar rather than to either of the boards.

To be honest, swiping from the edge while riding isn’t my favorite thing either. It would be even better if we could tap the leaderboard or rider list areas to restore them, but I suspect this is an edge case anyway and you have quite a few more important UI/UX things you’re working on so simply fixing the issue (if it is indeed an issue and not just me) is perfectly fine with me.

I’m on an iPhone, but it probably works the same. To swipe the leaderboard away, I have to first click on an icon on the action bar that brings up a submenu, like the view/camera icon. While the submenu is displayed (thus keeping the action bar from popping up/down), I can successfully swipe away the leaderboard and nearby riders. You likely have to do the same when swiping to get the leaderboard back.

3 Likes

Thanks, Travis, I confirmed that does work on an iPad as well. I’ll keep that workaround in mind while they hopefully work on the raft of iOS issues that seem to have popped up recently.

2 Likes

Since I started using an iPad mini (6th Gen., iOS 17.2) for Zwift I never ever managed to make the leaderboards appear. Sometimes I manage to swipe them away. And then I lost them until I get close to the next segment.
The work-around above does not work for me. Has anybody managed to swipe the leaderboards back on to the screen on an iPad mini? This is super annoying.

1 Like

Nope. I can swipe them away on iPad. But no possible way to get them back. Same for leaderboard. Goes away no problem but can’t get it back unless I completely close the app and restart.

Nope. None of these work on iPad, not swiping from the edge, not clicking the bar first.

I started losing the lists on iPad again. Bringing up an action menu sub list lets me swipe the rider list back in. A persistent bug!

1 Like