New Release 8/25 Issues: Strava short by 28 min, Garmin missing, Fit file corrupt

Strava workout loaded, but was short by 28 min. I rode for 1 hour
Garmin workout missing completely
Fit file downloaded and won’t upload to Garmin, shows “an error occurred, please try again”. Tried again and same error. Opened the fit file and it has nonsensical characters and is corrupt

Hi @Amy_Purvis

Welcome to the forums.

That usually indicate that you had a network issue during the ride.

1 Like

i put in a support ticket. It was also a release last night.

Hi @Amy_Purvis welcome to Zwift forums.

We were doing planned maintenance yesterday that affects your Activities feed and there was an issue that carried over to today. It’s possible that your report was caught in that lag.

Activities will take a few hours to publish. Please check again later today to see if the discrepancies are resolved?

Ok thanks. The activities is there, just didn’t know if the corrupt fit file would self-resolve or I needed to have it regenerated.

Our server team is looking into the FIT file issues to ensure that they won’t break moving forward. I’m not certain that ones that broke will reprocess.

Online tools like have a pretty solid success rate if you’d like to try it.

Just tried it. It has specific fixes. This file is just corrupt and creating an error. I don’t know what part is corrupt. Thanks

You can run, say, the Peak Remover and ask it to remove any heart rate over 200, or a HR higher than your max, it will process and tidies up the corruption, sometimes.