New pc with 12100F / 1660 ti only seeing 25-30fps

I just replaced my motherboard and cpu - upgrading from a 4790k to an 12100f (Asus prime-h610i mb).
I’ve been using it with a 1660Ti graphic card. Running 4K Ultra on a 4K monitor. Windows 11.

The 4790k+1660ti have been doing around 35-70fps on average…
But, been experiencing this extremely annoying “push pull” / zoom in and out / springy camera view when framerate goes from over 60fps to under fps or something.

Thought upgrading the CPU would keep the framerate above 60fps.
But with upgraded mb+cpu the framerate is even lower. On the menu gpu is running at 120w and 80fps , but as soon as we get into watopia framerate drops to about 25fps. GPU is running only 50% / 60w and cpu about 50%

I have vsync off, tried triple buffering both on and off.

Why is the new setup worse? I thought the 12100f was a great cpu for Zwift?

Turn off video screenshots.

You’ll have had that automatically appear with the new CPU.

Come back to us after that as there’s other possibilities.

1 Like

As per @Run.10K.Every.Day comments plus both triple buffering and threaded optimisation should be ‘on’. If none of this helps check your cpu cooler is properly fitted.

CPU cooler / paste was my next theory.

1 Like

Ah, I’ve forgotten to turn off the video screen, of course. That helped. With that off, in a Watopia pacer with 100 people, I’m now seeing 50-55fps, so still a bit low?
And solo in Watopia now up to about 75fps.
(Cpu utilization now at 33%, GPU still about 60% )
Both Threaded Optimization and Triple buffering are set to on in the Nvidia Control panel.
CPU cooler is fitted good with a quality thermal grease Dezen 12 W/(mK). Stock cooler, but nice and low temps about 50-60 (ambient is 5deg in garage). Running solid at 4.1ghz .

It should manage a stable 60fps, yeah. the first thing i would do is set my global FPS limit in nvidia to a couple FPS higher than the refresh rate of my monitor and enable vsync for zwift. i forget the reason why, but zwift apparently performs better with vsync enabled. how are the thermals? if a cpu is running hot it will throttle the performance. you can check those with something like hwmonitor while zwift is running edit: sorry wrote that while you were posting your temps, they’re fine

looking at your fps, honestly… i wouldnt be surprised if they were normal. i use a 12100f with a 1060 and get about the same in 1440p. zwift really does just run like crap on PCs. if i run it on my work PC then i get about 100 FPS in 4k with a 4070 and a 12700

I’d knock it down to 1440 as opposed to 4k given your GPU.
To the average eye you’ll not really notice the difference, especially not during an activity.

If you can then pedal harder!

yup still rough as hell. it really is just that bad

Vsync back on of course gets a stable ~60fps outside a pacer group, but seem to drop into low 50s in a pacer, still. Did think it would cut to 30fps when not managing 60?

Not seeing cpu temp above 60. Average about 50.

Also tried 1440p now. Pretty much able to keep it at 60fps in a pacer then, but drops a bit down in the 50s then also.

Quite dissapointed, as zwiftalizer shows 12100f + 1660ti setups at 80fps in crowded Watopia Ultra + 2160.

Don’t think I saw any of the “push pull” springy camera deal now, so if I’m rid of that it really is a win anyways!! (and the pc now boots in 10sec, and loads zwift in like 20 - probably thanks to m.2 ssd vs sata 3 ssd)
I’ll give it a try to see if the springy camera deal is gone - then I might be perfectly happy with 50fps…

yeah, this is actually pretty recent. not too long ago zwift released a patch which updated some of the graphics, changed some textures etc, but it killed everyone’s frame rate. at the time i was getting 60 fps on this pc, down from 144+, which is what my refresh rate was set at. it uses less of the processor than it did before the patch for whatever reason, at least according to the hardware monitor software i use, not sure what’s up with that

when i flagged it as a bug the response was “60 fps is still really good, right?”, which was disarmingly funny, and i don’t actually zwift on this thing so i guess i’m not gonna ride zhq about it too hard. and last time i checked it was <90fps average, so it seems to be improving a little patch by patch

1 Like

Video screenshots.

It really does have an odd effect at times.

1 Like

Video screenshot really was the huge performance killer! It should be off by default when installing Zwift!

Funny that you can still record screen with OBS Studio at zero FPS penalty.

1 Like

yeah. i want to use video screenshots but you kinda cant, hopefully they get that optimised too, but i’m not holding my breath. glad you got it at least running halfway decent

Weird that they can’t improve this ! Adding some multithreading should improve the game performance?

I record races with OBS Studio, but mostly for reviewing key areas of race, and analyze my tactics…

OBS is great, i’d recommend anyone with a PC use it. supposedly zwift has problems making fundamental changes to how the game runs because the engine it’s developed on is proprietary, old, and apparently just not that easy to iterate on. still, if sony could get a running recording feature going on the ps4 and still have games look and run pretty well on what is basically a potato now, i’m hoping zwift can manage it on a modern pc…

i saw a technical explanation by a dev about what actually causes these FPS drops in high end hardware, and while the details went over my head, i understood enough to see that zhq are rather painfully aware of the issue. i guess most people use android or apple anyway

1 Like

To be honest your frame rate is still low. Do you have one drive or similar running…? Anti virus software running…? Can you post a link to a ziwftalizer file…?

Might be worth joining the ZPCMR - Zwift PC Masters & Riders Public Group | Facebook group as there is a lot of knowledge there specifically for a rig like yours.

@Neil_Allonby_IRC , I did a race just now. Here’s the log I dont know how to add link here on the forum, but its: logreport/82758af4-6c61-4f20-ac35-f23690430c48

Windows is fresh installed, only bare minimum programs. No onedrive, no antivirus.
But for this one, since it was a race, I was running both OBS studio and Sauce! (no map on Sauce)

Mostly I found it to be OK, but had some areas where this “pumping”/zooming in and out occured. I really hate that. FPS when it happens is between 50 and 60, so I find it strange that it doesn’t happen all the time.
I can join the facebook group and post the video there…

Sauce is a drain, I know that for sure. The analizer will let you capture a link you can post here, anywhere else but it’s worth joining the group for more knowledgeable comments than mine tbh…

By the way that zooming you are getting is called rubberbanding….its a known thing, happens around 60fps I think, but again the resources in the group are better placed to assist with that one.

The forum will not let me add links. But if you add zwiftalizer dot com and /public/82758af4-6c61-4f20-ac35-f23690430c48 it should work?

Here you go, this is your ride…Zwiftalizer 2.0

.join the group as thats too low…