New Kickr issue

So I tried to attach my 2019 Trek Checkpoint SL5 with 12/142 thru axle on the brand new Kickr 20 today. I did remove the cassette that came on it and installed a Shimano 11/36 that matches what’s on my rear wheel. Should be no issue with compatibility.

Problem is, the thru axle goes in only a little bit for being forced to stop as if the inner cylinder has been narrowed not allowing complete insertion. Opened a ticket with Wahoo but just wondering if anyone else has experienced this. So bummed and frustrated.

Did a thru axel come with the Kickr?

Mike, do you mean a thru axle adapter? Or do the new trainers come with an axle?

No. Just the standard quick release found on 130 and 135mm. Instructions are clear to use the thru axle that came with your bike. It does come with 142 adapter kit and both fit the thru axle on my bike separately as I was attempting to solve the problem. But the issue appears to be within the cylinder of the trainer as if it was machined to the proper size. I realize that’s a bit of reach as that would be a major issue but I’ve run out of ideas.

1 Like

*correction - NOT machined to the proper size

I figured it came with one, but I must be mistaking that for the adapter

@Matthew_Shrader - odd problem! So you tried adaptors on your axle and all good, tried axle without adaptors on Kickr and no good. Aprt from maybe something left in that could be extracted, I suspect you will have a replacement coming soon! Keen to hear the outcome.

@Mike_Rowe_PBR - Thru-axles (142/148) tend to have varying pitch which is why you have to use the one that comes with the frame (I have 4 mtb’s and a gravel bike - only 2 mtn bikes share the same axle spec). Good to have standards in this industry.

The thru axle from my bike simply will not fit through the inner cylinder of the trainer. With or without the supplied 142 adapters. Tried every which way but no go. I too thought perhaps something was in there but can’t see anything. Maybe it just comes down to a machining issue. But if that’s the case, I’m surprised to be the only one with this problem. Hope you’re right and an a replacement resolves the issue. Guess it back to the Snap for now.

1 Like