Mayan Bridge Loop is misrouting runners [April 2022] [SOLVED]

Selected the Mayan Bridge Loop run, completed it, and the top centre onscreen graphic then showed I still had 2500m to go - suffice to say I didn’t get the route completion banner :frowning:


Mayan Bridge loop running doesn’t award a badge. Also it seems to go for a lot longer than “advertised” with distance to go showing in thousands of meters (eg. 2340) even once the 5.something km loop is supposed to have ended. Screenshots attached.

To get the badge, it’s a 5.7 km lead-in (from the Road to Sky start pens all the way to the Jungle banner at the bottom of the jungle) followed by one complete 5.3 km Mayan Bridge Loop lap (finishing back at the Jungle banner). I had to run just over 11 km in total. Do you think the progress bar is set up wrong?

The route for the Mayan Bridge loop misses the first left-hand turn, but the distance counter keeps ticking down to the route length. When you hit the “completed” distance, it shows ~9k feet left to go, and starts counting down like you’re in the homestretch - but you’re not even actually on the route. Also, the release notes indicate this is a run-only route, but there were bikes on route the whole distance. Is the only bike-free stretch after the turn that was missed?

1 Like

Mayan Bridge Loop Running Only (5.3km/3.3mi, 48m/157ft of elevation gain

Tried to run this route today but there appears to be a bug with it. During the ToW the route started at the pens, went through the main jungle loop banner and did a short loop of the jungle cutting across the Mayan bridge. Today the route started just before the jungle banner but instead of turning left across the Mayan bridge my avatar carried on towards the hanging bridge for a full lap of the jungle.

I’ve run the Mayan Bridge Loop twice once yesterday and again today and both time when the countdown hit 1 mile to go it went to 8234ft but kinda got stuck there. I for sure ran more than the last mile required to complete the route but the countdown never really moved from 82…ft. Perhaps there’s an issue with this.

Shane Besler

Hey all- I’ve split your reports off from the 1.24 game release notes thread.

Thank you for raising this to our attention - we’re investigating it.

1 Like

I think the counter gets stuck at .1miles to go not my previously noted 1mile to go. Of note I did the loop within a “plan” workout however today was done as a free run.

I raised this issue yesterday. Was told it was my “network connection issue”, which is unlikely as I have a solid connection. I was told to reinstall Zwift and try again. Did that. Same issue when I ran again today. Saw someone in messages complaining about the same thing. Definitely not an isolated problem. FYI this is on Apple TV

Mayan Bridge Loop is cursed. This much I know.

1 Like

Run only, meaning, you can only select this route if running. No option when we are on our bikes. Have to put up with pesky cyclists buzzing by but they can’t get a route badge. Wait neither can anyone running right now!

Aha! thanks for the clarification, John! I cycle too, so don’t mind the bikes, just was hoping to see more than 1-2 runners on the route - which is the case and I find it to be a great route all in all. :slight_smile: Ride on! :smile:

Happened to me, exactly the same. So I sucked it up and continued again. 10 miles later, same results. It just sucks.

The only game play update for runners for over a year and it doesn’t work. How on earth are we supposed to grow the user base with this sort of support? It’s almost as if Zwift HQ is inviting Zwift Run to fail.

1 Like

Mistakes do happen. Hope they can fix it soon.

I guess it’s a bit of a chicken & egg thing. If a free beta doesn’t already attract a certain number of runners, maybe it’s not worth investing in.
But without enough investment…

Must say that the Mayan Bridge Loop does look gorgeous.

1 Like

UPDATE April 18

We continue to work on resolving this bug as soon as we can. It has not been fixed in today’s game release v 1.24.1


If it’s of any help to the folks at Zwift HQ and probably the badge hunters out there. If you select the route but manually navigate the left turn across the Mayan Bridge (the next left turn, and the left at the Alpe junction are done for you) you reach the Jungle Arch after 3.6 miles and are awarded the route badge even though the route progress bar has disappeared.


1 Like

Update April 20

Bug ID’ed. The fix for this bug will be in the next patch. Don’t have a firm release date for it yet, but we wanted to let you know and appreciate your continued patience.


Is the handful of gravel running route available or is that still event only?

UPDATE April 22 - Zwift game app v 1.24.2 fixes this bug, and is available for all OS platforms. Please update at your earliest convenience.