macOS Monterey: cannot establish Bluetooth connection [October 2021] [SOLVED]

After upgrading to macOS Monterey (MBP15”) Zwift cannot establish Bluetooth connection.

Upgrade to Monterey
Start Zwift
Wait for pair devices screen
Don’t see any device BT device
Even my BT mouse and keyboard loses connectivity to MacBook
Close Zwift
Mouse and Keyboard are able connect again

Try the fixes below. Since you upgraded versions of MacOS, I would bet that deleting the plist file will solve your problem :man_shrugging:

Thanks for your message. I have tried, same result.

I assume you tried removing the plist file and rebooting. If that didn’t work, I would remove all devices. If it still doesn’t work, reset the bluetooth module. Still broke, reset the NVRAM/PRAM. And if you’re still out of luck, try an SMC reset.

Bottom line, you’re dealing w/a beta version of MacOS. So, it could just be a nasty bug which will require you to wait for the next build/release.

My whole point is the second case… this is beta version of macOS which probably next month will become GA and give you a feedback. I believe there are just few users who are running Monterey. In case I can help to do some a validation on the field. Let me know if you will need some log files from the app.

PS. Removal of all devices doesn’t help. Unf PRAM reset is not a. Option for me

1 Like

Same here. I’ve tried all the usual fixes but still the same.

If you check out the Zwift log you see that BLE is actually powered off for some reason after 20 seconds. My mouse etc is also lost and am unable to do anything BLE related…

[7:50:41] BLE : bledevice - Using background callback processing.
[7:50:41] BLE : CoreBluetooth BLE hardware is powered on and ready
[7:50:43] BLE : Starting Native BLE search
[7:50:43] BLE : BLE is Powered on
[7:50:52] BLE : CBCentralManager State Change
[7:50:53] BLE : stopScan called.
[7:51:02] BLE : CBCentralManager State Change
[7:51:11] BLE : CBCentralManager State Change
[7:51:21] BLE : CBCentralManager State Change
[7:51:22] BLE : CoreBluetooth BLE hardware is powered off
[7:51:31] BLE : CBCentralManager State Change
[7:51:32] BLE : CoreBluetooth BLE hardware is powered off
[7:51:51] BLE : CBCentralManager State Change
[7:51:52] BLE : UnpairAllPairedDevices

Thanks a lot, I have spotted the same in the logs, this happens always on Ttjis Zwift screen. Something makes it turn off BT connectivity on macOS (I cannot even use my BT mouse)… after exciting this screen or Zwift I can use my mouse again

I’ve had this same issue ever since installing Monterey (months ago, I’m currently Lifting with my iPad because the laptop just does not work AT ALL with Monterey installed). It being beta, I hadn’t raised it as an issue (I have mentioned in support email). We’re at the point now, though, that Monterey is eminent, and this is clearly VERY broken.

I can open my System Preferences to the Bluetooth panel and see everything just fine. If I start Zwift (and shrink the window down to see Zwift and System Prefs at the same time), everything is still there, but a couple of seconds after trying to connect devices, the System Preferences Bluetooth panel goes completely empty (and Zwift doesn’t find any devices). A couple of seconds after quitting Zwift, the Bluetooth preferences dialog is populated again and everything reconnects.

This is CLEARLY an issue with how Zwift is managing it’s bluetooth connectivity that is not at all compatible with some change in Monterey, and once it is GA, there will be a LOT of users very upset. Zwift should already be testing Monterey and should be seeing this behavior. If you are testing and not seeing it, then I’d be happy to assist in trying beta releases, sending logs, etc.

I’m a developer and understand that sometimes these things can be tough to pin down (given the Zwift user base, I’m sure there are many of us). I want it to work with Monterey (clearly) and will be happy to provide whatever help I can.

Yes, this is exactly the problem I’m having. Bluetooth and Zwift have been a growing problem on my Mac. Months ago Zwift would only run when paired with the companion app. Now the app shuts down Bluetooth completely. Hopefully there’s a fix soon.

Still an issue on Beta 7 (22 Sept).

Beta 8 (30 Sept) doesn’t resolve the issue. Definitely a Zwift issue.

All - thanks for flagging this up. We’re working with Apple to resolve this issue.

1 Like

I’m not sure this is related - Bluetooth is enabled on OSX 11.6 but in the pairing screen, there’s a warning icon under the Bluetooth icon.

I usually use ANT+ so never cared but this Frontier X HRM only pairs over BTLE and I’ve had to pair through the companion app.

Same laptop can connect to other BT devices.

Beta 12: still no love. Not being able to run a Public Beta on my Mac because it breaks Zwift…not ideal. Any updates @shooj?

Don’t have an updated progress report. We’re aware that Bluetooth doesn’t work with OS12 beta, and we are working on it.

Thanks @shooj. The task of maintaining lots of OS hardware and software seems insurmountable. I hope, in the future. Zwift can have beta plans for those who test hardware and software for other reasons.


@shooj, just to be clear, there is another thread I’ve started about Mac OS 12 Beta as it simply won’t load. Is this because of bluetooth, or separate issue?

@shooj Monterey due next week. Any news you can share would be appreciated.


Zwift has enough problems w/current released versions of operating systems and you want/expect them to be concerned about Zwift working properly on Monterey which is a beta version :joy: :joy:

1 Like

When Monterey is released - the other developers should be ready for it because people will update their macs to it pretty quickly. Better to be prepared and avoid getting slammed by people upset by things not working.

1 Like