Mac OS Latest Update repeatedly downloading

Trying to update and after Download goes to “Preparing Update” then starts Downloading all over again… Been repeating this for an hour…

It’s been 3hrs since your post. Did this sort itself out? If I had to guess, an issue w/the server(s) you were trying to download from :man_shrugging:

Hi Lin,

No I am still having the same issue on both of my MacBook Pros. Exactly the same sequence - the download ends, it goes to preparing update and the the download starts all over again… I tried last about 30 min ago.

Thanks for the feedback… Let me see if downloading over a VPN improves it…


I now can’t use Zwift on both my machines… this is hopeless!!!

Two laptops with same problem :thinking: Bizarro!

VPN didn’t help?

I only have my work MacBook at the moment. I downloaded the installer and installed Zwift. When I started it, it took several minutes to update. I have never seen an update take that long in all my years of Zwift. In any case, Zwift started w/out issue once it finally updated.

Perhaps try a clean install. Move Zwift to the trash. Empty trash. Start from scratch.


I did a full clean install but it installed the earlier version and then tried to update. Same issue as trying to update in the first place…


That really sounds like the CDN you’re downloading the update from is hosed. If you can use the VPN, especially if you can change your geographical location w/the VPN, you could get a diff CDN server and then the update would work :man_shrugging:

I tried again with VPN and a different location and it took an age but this time it worked… Thanks

1 Like