Mac, iPad, iPhone issues


(El Senor) #1

My mac bluetooth has never picked up my kicker.

My iPad bluetooth does and has worked great until recently.  Now everyone looks the same, the new routes do not come up, the one month 10,000 foot challenge isn’t available and I the custom workout is not an option.

Iphone - Everything that iPad is doing wrong, iPhone does right EXCEPT the resistance does not change ever.  

Any ideas?  I’ve unplugged, turned off, restarted etc everything.  


(Paul Graham) #2

Your native Mac Bluetooth is not supported by Zwift Adam.

Are you using your iPad/iPhone as a bridge to your Mac or are you playing the Zwift game on the iPhone/iPad?


(El Senor) #3

I’m using iPad and iPhone as stand alone devices.  Look at it this way, mac doesn’t work, next!  iPad is kinda working, next!  iPhone is kinda working.  Go back to iPad bc it’s working the best out of the 3.  Are you saying that using one of these devices to bridge to the mac could be a solution?  I’ll try it but will I see what I see on that individual device?  Example:  If I use the iPhone to bridge, will the mac show what the iPhone shows?  If so, that’s no good bc iPhone currently doesn’t adjust to resistance.


(El Senor) #4

Is the solution to do an ant+ cable from the mac to the kicker?


(Paul Graham) #5

@Adam

Installing an ANT+ dongle onto a USB extension cable would be my preferred method of connection.

I have used Bluetooth and ANT+ on setups in the past and have found ANT+ to be easiest to correct should it stop working.

Other than a few drops, I have never had any real issues with ANT+.


(Paul Allen) #6

OK, there is a little misinformation here.

Native Bluetooth IS supported on Macs. With Bluetooth you need to make sure that the trainer/HRM are not connect to ANY other device or app before opening Zwift.

I would echo the recommendations for using ANT+ with a USB extension.


(Paul Graham) #7

Thanks for the correction Paul.  

My comment about native Bluetooth on the Mac was incorrect. My apologies for any confusion Adam. :slight_smile:

Ride On!

 


(El Senor) #8

Ok, turned off iPhone, turned off iPad and the mac worked.  Thanks and that’s great.  Now, I need to find out how to get iPhone to work - resistance not adjusting with my kicker and iPad - resistance works fine, but not everyone looks the same, the new courses are not available and the 10,000 foot challenge is not an option.


(Paul Allen) #9

Adam,

Is your app up-to-date? It sounds like you may be running of an older version.


(El Senor) #10

Excellent question.  Any idea where to find the numbers of the latest versions?


(El Senor) #11

Update.  iPad and iPhones all powered off.  Mac did work once, not not at all.  Issues at large:

Mac not pairing. Running version 1.0.25225

iPad pairing.  Not showing new courses, 10,000 foot challenge, everyone looks the same.  Running version 1.0.22144

iPhone pairing.  Showing new courses and 10,00 foot challenge.  Resistance not adjusting.  I thought it might be that I need to go in and manually adjust the kicker resistance in one of the menu screens, however not finding that option. Running version 1.0.25222

Hearing crickets from zwift.  Appreciate your help Paul(s).  Ordering an ant+ today as lbs doesn’t carry any.  


(Paul Allen) #12

My iPad version is 1.0.25222, so you look like you are a little behind on that.

iPhone looks to be running the correct version.

Mack sure that the Kickr is not connected to the Mac in any way or any other device or app before opening Zwift. 


(El Senor) #13

Update.  I updated iPhone and iPad.  After doing a calibration, iPhone working.  iPad still not.

Mac still not connecting.  Ordered ant+ from wahoo.


(Paul Allen) #14

Adam,

IF you are talking about the Wahoo ANT+ Key, I would recommend canceling the order and getting CABLE for the iPad and iPhone and getting a USB ANT+ dongle and extension for the MAc.


(Jurgen Doreleijers) #15

I think I have the same problem with my MacBookPro11,5 (latest macOS) running latest Swift 1.0.25225 trying to connect to Trek (Bontrager) duotrap ANT+/BTLE sensor. 

The sensor connects fine with my iPhone but not with the above mac. I already reset the PRAM of the Mac. I already disabled all other ANT+ and BT receivers nearby and reset the sensor by taking the battery out temporarily. 

Do I also need to shell out another €40 for a stupid ANT+ dongle? The BTLE sensor is supposed to work right?


(Jurgen Doreleijers) #16

The problem I described above was fixed by the advice given in the last item of a support request ticket reply I got from Zwift. TNow I can return the ANT+ dongle. hanks guys. 

|

|

The first thing I would recommend doing is reading this article on Bluetooth issues with Macs; it sounds like you’ve already gone through a few of the listed potential fixes, I would recommend trying the last two. They’re titled Removing potentially corrupt files and Resetting Bluetooth Module , both should help with your issue.

|

|

 


(El Senor) #17

Ok.  The Ant+ usb dongle has arrived and now my mac computer connects to my kicker HOWEVER the resistance does not adjust at all.  I cannot for the life of me find the spin down option on the screen.  This leads me to think that maybe there’s something I need to do besides just sticking the usb cord into the mac with the ant+ on the end.  Any ideas?


(Paul Allen) #18

El,

Did you pair it as FE-C


(El Senor) #19

No I didn’t.  I don’t know what FE-C is.  I’m going to look around and try to figure that out.  All I did was just plug the thing in.


(Paul Allen) #20

You need to connect your training within the Zwift pairing screen to the one that is listed as ANT+ FE-C.