Lost connections. Log entry: "[FTMS] Request took too long, resetting trainer" - writing for help w multiple recent dropped ZC to Zwift App connection

In the past week, my ZC-ZwiftApp connection has dropped 2-3x while I was riding an event and a free-ride. I have been using Zwift App/ZC/Kickr Core since mid-Dec and have had one or two occasional drops. This week sets a new PR. Interestingly, it did not happen when I did two 30 min workouts in ERG mode from a workout plan last week…

I tried a Zwift Ambassador but the reply time was very long between responses. I’ve followed the advice on a forum link to support at swift dot com. I got a ‘no reply’ 'email directing me to chat/IM support. Sigh. So I decided to re-post my issue as a separate forum topic.

About my Setup & a few other facts:

Smart Trainer: Kickr Core
Zwift app is running on MacBook Air was with Big Sur OS v11.6 (I updated to Monterey last night)
Zwift App automatically updated INCLUDING before I rode on Saturday
Zwift companion app is running on my iphone. I made sure it was updated after disconnection 1 and 2 last week. There were no updates pending when I rode yesterday, so it was updated before I rode yesterday
ZC and Macbook are on the same WiFi. Nothing is different about my setup or bike/trainer location that would explain a change (i.e. I didn’t move my bike further from WiFi)
I have a Wahoo HR Arm Band connected via Bluetooth which ZWIFT PAIRS.
Since I got my Kickr Core/joined Zwift in December 2021, I was never able to pair the Kickr Core directly to Zwift on Macbook using bluettooh – devices are never recognized – hence why I use ZC app.
Since ZWIFT didn’t crash, I did not find any Crash Reports.

Here’s additional info:

What happens when the connection drops: the blue box w/RPM, wattage shows me the connection has dropped. This has happened on events (a TdWatopia event) and free rides. Saturday it dropped after 25 minutes of riding, came, back briefly, dropped again. All three times over the past week, the wattage and RPMs on my smart trainer were wonky after I tried to ride again. I tried to do a spin down calibration after each time, and it could not find my device ‘FAILED’. I did two spin down calibrations after the prior to times. I gave up today. But each time I initially got the FAILED error.

Here’s a log snippet from when connection dropped on Saturday.

Log:
[17:58:37] Starting critical power curve search job (1997476) mTimeStamp = 1557.92859 m_lastSearchTime = 1547.90649 calculating=false
[17:58:39] [FTMS] Resending last request.
[17:58:40] FPS 24.65, -159752, 14809, 260647
[17:58:44] [FTMS] Resending last request.
[17:58:44] NETCLIENT:[ERROR] Auxiliary Controller received ‘Connection reset by peer’ (54) during message length receive handler
[17:58:44] NETCLIENT:[WARN] Auxiliary Controller failed to shut down tcp socket: ‘Socket is not connected’ (57)
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller shutting down keep alive loop
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at: 192.168.254.45:21587
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller connected successfully
[17:58:44] NETCLIENT:[INFO] Sending Pairing Status of: true
[17:58:45] Chat: Ami (B2B) 4105618 (World): Lena and I aren’t taking breaks. We’re strong
[17:58:45] LIVESEG: Sending Active Segments.
[17:58:47] Starting critical power curve search job (2007506) mTimeStamp = 1567.96924 m_lastSearchTime = 1557.96863 calculating=false
[17:58:48] FPS 24.25, -159042, 14808, 260026
[17:58:49] NETCLIENT:[INFO] UDP metrics {StC Rx: 829, Rx error: 0, CtS Tx: 292, Tx error: 0}
[17:58:49] NETCLIENT:[INFO] Failed one leg latency threshold test. [min: 562, avg: 2541, max: 4763, n: 89]
[17:58:49] [FTMS] Resending last request.
[17:58:54] [FTMS] Request took too long, resetting trainer.
[17:58:54] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:58:54] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:58:56] FPS 23.70, -158507, 14811, 259664
[17:58:56] Phone requested profile. We know about player 3188051 but don’t have the profile yet. Still waiting on the server
[17:58:56] Phone requested profile. We know about player 4777564 but don’t have the profile yet. Still waiting on the server
[17:58:56] Phone requested profile. We know about player 573577 but don’t have the profile yet. Still waiting on the server
[17:58:57] Starting critical power curve search job (2017575) mTimeStamp = 1578.03284 m_lastSearchTime = 1568.00928 calculating=false
[17:58:59] [FTMS] Resending last request.
[17:58:59] Chat: Ami (B2B) 4105618 (World): P)
[17:59:04] FPS 22.94, -157503, 14830, 258974
[17:59:04] [FTMS] Resending last request.
[17:59:05] num=1584 NP = 94.12 IF = 0.82 TSS = 29.47
[17:59:05] Loading WAD file ‘assets/UI/WhiteOrangeTheme/JerseyIcons/JerseyIcons.wad’ with file.
[17:59:07] Starting critical power curve search job (2027650) mTimeStamp = 1588.10327 m_lastSearchTime = 1578.07483 calculating=false
[17:59:09] [FTMS] Resending last request.
[17:59:12] FPS 21.79, -156623, 14866, 258326
[17:59:14] [FTMS] Request took too long, resetting trainer.
[17:59:14] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:59:14] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:59:17] Starting critical power curve search job (2037709) mTimeStamp = 1598.16675 m_lastSearchTime = 1588.14929 calculating=false
[17:59:19] Chat: ena (B2B) 150928 (World): Awe thanks Ami x
[17:59:19] [FTMS] Resending last request.
[17:59:20] FPS 21.55, -156063, 14903, 257852
[17:59:24] [FTMS] Resending last request.
[17:59:27] Starting critical power curve search job (2047764) mTimeStamp = 1608.22144 m_lastSearchTime = 1598.21277 calculating=false
[17:59:28] FPS 20.99, -155623, 14937, 257507
[17:59:29] [FTMS] Resending last request.
[17:59:34] [FTMS] Request took too long, resetting trainer.
[17:59:34] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:59:34] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:59:36] FPS 21.01, -155229, 14969, 257187
[17:59:37] Starting critical power curve search job (2057850) mTimeStamp = 1618.30212 m_lastSearchTime = 1608.26746 calculating=false
[17:59:39] [FTMS] Resending last request.
[17:59:44] FPS 19.95, -154863, 15003, 256881
[17:59:44] [FTMS] Resending last request.
[17:59:47] Starting critical power curve search job (2067916) mTimeStamp = 1628.36743 m_lastSearchTime = 1618.35217 calculating=false
[17:59:49] NETCLIENT:[INFO] UDP metrics {StC Rx: 517, Rx error: 0, CtS Tx: 300, Tx error: 0}
[17:59:50] [FTMS] Resending last request.
[17:59:51] ZML_SendMobileAlert Succeed, Title: END RIDE, options count 2
[17:59:52] FPS 22.22, -154512, 15035, 256581
[17:59:53] NETCLIENT:[INFO] Sending telemetry…
[17:59:53] SaveActivityService::EndCurrentActivity with {activityName: Zwift - Tick Tock in Watopia, privacy: FRIENDS, hideProData: False}
[17:59:53] SaveActivityService FIT_CloseFile
[17:59:53] SaveActivityService GAME_SaveStockImage with {activityId: 1038651769887932432, worldId: 1, playerId: #############}
[17:59:53] Skipping beauty screenshot due to ZWIFT\CONFIG\IMGPREFS value: 2

In the absence of any insight so far about what is going on I plan to do the following:

calibrate my Kickr CORE using Wahoo app, not Zwift.
possibly re-set my Wahoo Kickr Core
ride today with my iphone on Airplane mode and only connected to WiFi in case the mobile service was causing an issue.

Is there anything from the logs that explains what is failing or what is happening? I am wondering if it is a KICKR Core issue, but i can’t call Wahoo on a weekend.
I appreciate any insights and help.

Do you have an external cooling solution for your MB Air? People are reporting increased power demands with latest updates. It could be the Air is overheating with the increased demands. Excellent idea to put phone in Airplane mode in case your phone is attempting to use cellular data. Have you tried running the Zwiftalizer to analyze your log file? Resetting/restarting everything including router/ modem is always a good idea.

@avid_dk Hi David, thank you for the reply and ideas. I don’t have an external cooling solution, but that sounds like a good idea…I’ll look into what’s recommended. I have a small stand that has two fans, I’ll have to figure out if/how they work.

I tried a few things from Wahoo, Zwift and SmartBikeTrainer sites. I did the following (including the OS update) and it seems to have been successful as I rode for an hour with no dropped connections:

  1. Unplugged the Kickr Core for 30 seconds minimum (per Wahoo site suggestion)
  2. Performed a spin down calibration using the Wahoo app.
  3. Closed the Wahoo app (did not tell it to ‘forget’ the Kickr Core but that would have been a next step)
  4. Put the iphone on airplane mode and connected to WiFi
  5. Deleted all bluetooth devices from the Macbook Air (none were ever active)
  6. connected Kickr Core to Zwift App on Macbook Air with blue tooth not the ZC app

Today was the first time I connected the Kickr Core to Zwift on the MacBook Air using Bluetooth without the Zwift Companion App! I rode with that setup today, so did not even use the Zwift Companion to connect the Kickr Core For this issue, I think removing all mentions of bluetooth devices from the MacBook Air helped though I have no proof. None were ever active, but I could never get the macbook to recognize the devices, so I always used the ZC app. It’s nice to have two ways to connect now.

Rika,
Funny you should mention removing all Bluetooth connections from the Air. I recently deleted all mention of Bluetooth devices on my Mini so the only devices connected are my Stage bike and FA power meter pedals. Maybe there is some MacOS limit or regular polling to check if devices are present that causes dropouts. I have completely given up using Bluetooth headsets if even only connected to my iPhone. Somehow MacOS throws fits about that. I hope all continues to go well and check back if it doesn’t.

@avid_dk - I had my bluetooth headset, turned off but nearby yesterday, so today I moved them to another room and even turned my ipad bluetooth off. I wanted to eliminate other interfering possibilities. I guess you could say I had no idea what was going on, so I figured, why not?

Oh, and thanks for the tip about Zwiftalizer. I just learned about it earlier this afternoon. I will take a look at that. Seems complicated and my brain probably needs a rest after all of the learning I did for this issue!

Thank you again.

Hi @Rika_Bikes

I had a look at your account and it seems that up until today’s ride, you’ve been using the ZC BLE bridge to pair.

That being said, since you switched to using the built-in Bluetooth LE (BLE) connection on your MacBook Air, did your devices still drop the connection from Zwift or have matters improved?

The ZC BLE bridge can lose the connection for various reasons – the most common ones being WiFi dropouts from your phone or other intermittent issues with your WiFi network, so I suggest you check out our related article for troubleshooting this kind of issue.

If you’d like to contact Zwift support, we do not recommend sending an email to support@zwift.com.

Doing so will likely result in a “no reply” email, which doesn’t reach our team. Instead, I’d suggest contacting us here.

After going through the initial Solvvy portion of the support process, you may be directed to try a chat with a live agent first, but you can opt to email us for support instead.

Hi @Steven_D

Thank you for taking a look! I have been using ZC BLE bridge since I got my Wahoo Kickr and joined Zwift in Dec 2021. I couldn’t get anything to pair with built-in Bluetooth LE (BLE) connection on my Macbook Air, till yesterday. After I completed all the steps I mentioned above, I had a problem free hour-long ride using the Macbook bluetooth. I won’t ride again till Tuesday, so I’ll see how the ride goes.
Thank you also for the tips about contacting Zwift. The chat was a challenge, so I will opt for email in the future.

@avid_dk - I did use Zwiftalizer to get an analysis of the log per your recommendation.


There were Bluetooth FTMS Message Resends, Bluetooth Trainer Resets, UDP Network Disconnects at the end of the log when my avatar just stopped riding. Not sure what it all means, but that’s what stands out.

Erica

1 Like

Erica,

I am reading the Blog at Zwiftalizer that describes these messages. It appears that your trainer is not responding. I wonder how your MB air is located in relation to your trainer. Re-reading your comments I see that nothing has changed in your setup as far as location. I think you should unplug your trainer after every ride. How about a factory reset?

1 Like

Hi @Rika_Bikes

You’re welcome! Also, it’s great news to hear that when paired via native (built-in) BLE, you didn’t have any issues with dropped BLE connections. That might be your best bet going forward assuming the KICKR is able to consistently pair.

We also have this article for Mac-specific BLE troubleshooting.

There are a lot of things to try in the article, but any one of the suggestions could help, so be sure to try them all if you run into any further trouble with the built-in BLE on your Mac.

I noticed you’ve written in to our tech support team as well, so I’ve moved your support inquiry to our Tier 2 tech support queue and you should be hearing back from a tech support agent shortly. Thanks!

1 Like