Location Error

Zwift app on HP x2 Chromebook randomly started giving location error message

I’m new to Zwift, had been enjoying my setup using the android app on my Chromebook and using the Companion app on my phone. I started up a workout and receive the Location error message.

“Location Alert Location is off, Please enable LOCATION in System Settings”

I’ve deleted and reinstalled the app.

Rebooted the system.

Searched for similar problems, could not find any.

Any help is appreciate, thanks.


Also have the same problem.

This used to work ~2 patches ago.

Please fix

Hi any resolution on this? I am having the same issue.

I know nothing about Chromebook, but Android wants also Location switched on for Bluetooth… Don’t ask me why (big brother Google is watching us?).

Looks like I have the same problem. ‘Location alert, location is off. Please enable location in the system settings’. Everything is enabled on my android tablet. Last week it worked fine, now my Tacx cannot be paired.

Bonjour, J’ai désinstallé puis réinstaller mais rien n’y fait Avez-vous des solutions à me proposer pour m’aider merci d’avance

Same issue here, worked fine last Saturday (9th). Patched Zwift today and now getting the error message.

1 Like

On a Chromebook go into settings (bottom right), apps, Google play store, manage android preferences, security and location, turn on location.

Should solve the problem but it currently seems to default/reset to off which is a pain. Hopefully next Chrome OS update will resolve.


Yes same issue here. Was working on Monday and stopped working on Wednesday. Get a location error and my chromebook doesn’t connect to my trainer. Try to reboot, reinstall zwift. Nothing worked so far.

1 Like

Bonjour, il faut réinitialiser la localisation de la tablette, car dans ce cas j’ai une tablette, et vous pourrez vous reconnecter.

Same issue here on a Google Pixel Slate tablet.

I figured out to resolve it now on my Pixel Slate Chromebook. I created a second user and during the user setup process it asks you if you want to share location. After choosing yes during the setup I’ve had zero issues. I must have selected “No” during my initial setup

same problem here. cant find n solution. :frowning:

solved. ty!!!

How did you solve this problem? I tried to create a new user, and i was not asked to share location or not. I still get same “LOCATION is off” error.

I also have Google Pixel Slate and running v 61590

I also have an HP x2 Chromebook running the Android app and I experienced the same problem…the app’s insistence on enabling location (to enable bluetooth pairing as per Android regime).

When I checked my location settings (Settings - Apps - Google Play Store - Manage Android preferences - Security & Location - Location) it was enabled already and yet it didn’t work.

When I disabled location then re-enabled it…it worked! Strange but true. Or maybe the Zwift devs have changed something meanwhile. Up and running again.

Was the Zwift app available in the PlayStore?

Yes, but it only shows up if the device you are using is able to run it. Recent ChromeOS generally supports Android apps but it’s not universal, e.g. not on older Chromebooks.

Jon, where did you disable and reenable location on your x2? I’m done it as well, it hasn’t worked. What version are you running as well. Thanks.!

Same for me on a Google Pixel Slate, everything is up to date. I’ve disabled and enabled location in the app permissioms, still doesn’t work.