Google Pixel 6 - Connection issues

Hi, I recently purchased the new Google Pixel 6. Zwift isn’t connecting to the app on my phone. I cant see the device listed in the connection page. Nor does it show up.

I have enabled location services all the time.
Uninstalled the app and reinstalled it.
(yes check Bluetooth is on and working)

Without the connection working i’ll have to cancel this subscription.

It was working fine with the old phone.

Any ideas?


I had the same issue. After much frustration, I happened to unpair my devices from my phone. Then went to the Zwift app, and paired them from there. Worked fine. Very frustrating and somewhat counterintuitive though.

1 Like

I’m having the same issues with new Pixel 6. Cannot connect. I have uninstalled and reinstalled the Zwift app twice. Turned BT on/off, reset trainer multiple times and disconnected all other devices. The Zwift app is simply not seeing the trainer and/or devices. Any ideas suggestions would be appreciated.

I’m having the same exact issue with my Pixel 6 Pro. Have to revert back to using my Pixel 4XL. No idea why it just won’t connect. Even tried unpairing/repairing, uninstalling/reinstalling, clearing cache… nothing works.

Same for me on Pixel 6 Cannot find my Wahoo on Zwift. No issues via Wahoo app, seames to be a localized issue to Zwift and the Pixel 6

I am having the same issue, can’t pair my Kickr Core through my Pixel 6 phone. I have made sure the app permissions include bluetooth pairing and I have tried turning everything on and off multiple times.
Has anyone figured out a workaround?

I’m having the same problem with Sony Xperia 10 III.
The companion app doesn’t work as expected. From the bluetooth settings of my phone i can discover trainer and hrm, but when i use the companion app as a bridge, Zwift running on PC is not able to discover the trainer and hrm.
After a while, i found out that my old phone was working properly. So it could be a bug of the companion app on newer android OS.

I just got a Pixel 5a and was unable to get Zwift to recognize my Kickr or my Garmin heart rate strap. The Wahoo app was able to connect to both on my new phone without issue.
As others have also described, I tried every troubleshooting step imaginable and ultimately had to use my old phone to ride. I hope this problem can be resolved with an update soon.

Same with me. Customer support was no help. I am going to try Rouvy to see if my sensors work with their app.

Same for me, app not working with New pixel 6 ! What a shame…

Replying to Tom above:
Same and it did work. But it was a very painful experience and Zwift Support were less than helpful.

I have had the same exact issue with my Pixel 2. On my phone I went to settings>apps&notifications>ZWIFT>Permissions then I had to manually grant the app permission to use my location. Once I did this the zwift app paired first try.

I noticed that when I installed the app, there was never any prompt to give the app permission to access the phones location. I have relayed this information to zwift tech support.

Hopefully this helps anyone with the same issue.


My app permissions were automatically off. Had to open app info, and turn off this setting using the toggle switch. Not sure why the default setting is to have it off, but everything magically connecting for running and biking on my pixel 6 after making that adjustment. Good luck all!!!


I was just able to get my pixel 6 working with the location permissions change as well. Does anyone from Zwift watch these forums to get this info back to the devs so they can change the required permissions in the app so it will prompt people to approve it. This has to be effecting a LOT of people.

Edit: adding @James_Zwift to get word on this one back to support/devs as this is a really crappy issue with an actual fix they could make pretty easily (or at least add a faq or notify support).


Hi Matt,

I did, and up to email number 48. It’s an absolute joke. I cancelled my subscription untill it’s resolved.

I am not a developer, but there are different permissions the developers must declare for different Android versions:

Pixel 6 has Android 12, perhaps that’s problem - Google definitely changed the permissions for Bluetooth.

1 Like

Beyond my scope of technical knowledge but will flag.

1 Like

I am a developer, but yes that is exactly the problem. And the fix is just changing 1 setting in 1 file that is part of their build that tells android what permissions you require. The popup that asks you to okay it and all that jazz is native to android, you just have to tell it what you need. If they set that then whenever they do their next release it will just fix the issue, but who knows if the next release for the app is weeks or months out and LOTS of people are getting upgraded android this week so it would be ideal if they got something written in their tech support stuff for this quickly.

They are pushing newer android to many samsung device as we speak and zwift is gonna have a bad time if every samsung device stops working on new years resolution week.


Great hint. Location setting worked for me after I updated my S10e to Android 12 and had the same issue.
I needed to switch to DETAILED location (a new option in 12)

1 Like

This is exactly what I had to do on the Pixel 6 Pro. I had to grant the Zwift app permission to know my location among other things.

1 Like