Left standing at start of Toue De Zwift


(Lone Woof) #1

Myself and many others, (perhaps hundreds) were left standing ready to ride at today’s 2:00 PM (EST) start of the Tour de Zwift. There were maybe 5,000 riders! (if I read my screen correctly). What’s up? I rescheduled my day around this ride, only to have wasted the time. For what it;s worth, I ride a Wahoo Kickr with Apple TV. It has worked perfectly until now.


(Allen Day ) #2

The same thing has happened to me at the start of all three stages of TdZ so far. Everyone rides away and I’m stuck with little dashes for watts, HR, and cadence. If I go into the menu and play pairing games I can get it to work again. By that time a minute or three has passed and I finally roll away.

In a weird twist I’ve used my setup without any issues for weeks. I can do workouts and just ride around just fine without a single disconnect. My wife also uses all the same hardware and she has completed all three stages without a problem. I’m ultimately able to complete the stages, stages but it just isn’t as much fun when I have to wipe myself out trying to make up multiple minutes on the other riders at my level.


(Alexander McLeod) #3

Same thing happens to me. I find that by quitting the companion app and restarting it, I regain connectivity. But this only happens during large events. Not sure what is causing this, but it seems to be widespread.


(Gerrie Delport TeamZF) #4

It sound to me like while you were in the starting pen your sensors went to sleep.

When you arrived in the pen could you see your power, cadence and HR change on the screen, at what point did you notice that you can’t generate power.


(Alexander McLeod) #5

Negative - All sensors and trainer stayed active - I was actively pedaling during the pen time to prevent this. Disconnect happens roughly 15-20 seconds after the start of the event - so I get maybe 100-500 meters into the race before the disconnect occurs.


(Lone Woof) #6

At the starter bell or whatever. I was actually looking at all the other avatars, so I did not see MY POWER meter… I am registered for today’s Tour at 1:00 ( in 27 minutes). Could Zwift Companion have anything to do with it? It rejected my password for two days, then suddenly today it works… I am going to use it for the first time today. HEY I remember… it did tell me before the event stated that there was not enough Bluetooth “stuff” Bandwidth? Memory? I am a cave man. I don’t know the right words… That message went away, so i forgot it… I’m going to warm up now and sit in the “pen”…


(Gerrie Delport TeamZF) #7

@Alexander_McLeod: Ok thanks, the other thing could happen is that the computer had to calculate so many graphics operations that the bluetooth/ant+ stopped responding.

It will be interesting to see what happend in your log file.


(Russ Goff) #8

Yep exactly the same for me… not a good week for me so far. Was stuck with ‘finding riders’ for quite some time and when I ended the event a couple of times and finally got going it stated that I had 20k left until the end of the event, I got the leader board at 20k showing that it had finished so I continued to ride a further until clocked 36k. I got the confirmation email etc and got the credit but didnt experience a good ride as in the back of my mind I wasnt sure if I would get the credit. Just waiting on stage 2 confirmation now as I did the ride but it didnt say it was completed. im hoping the next stage will be ok


(Gerrie Delport TeamZF) #9

Hi Russ - did you joined the race late?


(Russ Goff) #10

Hi Gerrie,
Nope, bang on time. Waited for the count down then accepted the ride


(Gerrie Delport TeamZF) #11

@Russ_Goff: one more question, so you were riding around waiting for the countdown timer, did you wait till it got to 0 (or close to it) or did you go to the pen when Zwift auto transported you at about 4-5min to go?


(Russ Goff) #12

Ask away mate, Im happy to answer : ) I waited until zero seconds, selected ride now, and then I got the option to accept the event, which I did (before it was automatically selected).


(Gerrie Delport TeamZF) #13

This is what I think happens if you wait till the last second, you and a lot of other riders get transported to the pen but it take a bit of time because of the high load on the servers, so once you get in the pen the race has already started and you get seen as a late join and because there is so many late join riders it take some time to get you started and you may end up waiting a long time.

My solution is not to wait till the last second, go to the pen early (I go 5 min before the start) then sit there and spin, this will give you the best possible chance of a successful ride.


(Russ Goff) #14

Gerrie, thanks very much for for taking the time to respond. What you are saying make sense, I will take your advice, hopefully it will do the trick.


(Lone Woof) #15

Well, Gerrie, I got into Today’s 1:00 PM (EST) Tour de Zwift 3 and everything went perfectly. But before I started i got the message:

"Bluetooth is out of channels. Do you want to switch to your Zwift Companion?" Not understanding what would happen, and with one minute before start, I said “NO” and rode - I turned my smart phone totally OFF and it solved the problem!!!

So, am I correct in guessing that Companion interferes with Apple TV and Vice Versa? it’s got to be either APPLE TV OR Zwift Companion (but not both) running the show?. Forgive me - I am a cave man who hates much of this new tech.

The Apple TV remote is royal piece of *&^%%##!@! I will go with Companion next time, and not wait until race time to test it!

By the Way, I can see now that Zwift is going to change my life!! I’ve been getting fatter every winter, and not getting into shape until July. NOT THIS YEAR! My personal thanks to everyone involved with this innovative, useful, fun, and GREAT way to use technology. But It’s going to get very crowded. I hope you can deal with that without compromising the fun and flexibility of the program!

Username Lone Woof

real name: Douglas Keith


(Alexander McLeod) #16

Interesting, plausible. I wonder though, because the Zwift Companion app should be talking to the servers so to make this super basic (please correct me if I’m wrong): Information flow > Bluetooth sensors/Trainer > Smartphone > Zwift Server > PC (viewing the combination of inputs from the server and companion app).

So graphical calculations shouldn’t impact bluetooth as it happens ‘downstream’ of where the bluetooth information is being processed (smartphone). However, could the app itself be getting overrun with data somehow? Maybe, since because Zwift shows only the closest 100 riders (right?) and that information is constantly shifting during these large start group rides, that is what is causing the data interruption? The app is trying to update the “Zwifters near you” tab so quickly that the bluetooth sensors are getting the short end of the processing stick, causing a disconnection.


(Gerrie Delport TeamZF) #17

And that is why I use ANT+ for all my connections, it just take one variable out of the equation. I know some people may have sensors that is only Bluetooth so they need to use this method. I think once the Bluetooth Windows beta is out of Beta we would have one more option to try.

@lonewoof : Sorry I don’t have Apple TV so I cant test that.


(Colin O'Herlihy) #18

Agree 100% on the ANT+. I was having intermittent problems with Bluetooth when I first signed up, saw this advice online, purchased an ANT+ dongle (€15 for my one), paired with all sensors no problem and I haven’t had a dropped connection since.


(Max Power) #19

Same problem here using a Tacx Flow Smart trainer (latest firmware) connected through BT and the companion app on Android. Everything works fine during the countdown phase, then when the riders start moving, my Watts drop to zero and I see some lag on the screen (sometimes also bikes without riders). After a while, the Watts sometimes come back up just to get stuck at a random value while the cadence and my heart rate show up normally again. I also tried unplugging and re-plugging the trainer, re-starting the app but the Wattage keeps getting stuck at the same value.

I was able to ride the 4th stage normally after uninstalling and re-installing the program on Windows, but the issue happened again today when I tried to ride the Fondo. Super annoying!

My pc is an i5-3210M laptop with intel graphics running Windows 10. Not the fastest machine but zwift runs perfectly fine outside of large events.

EDIT: I just tried with my gaming pc (Ryzen 7 1700 CPU, Geforce GTX 1060) and the same problem occured at the start of the 3 pm CET Fondo event. I even tried 2 different Android phones with the exact same result. I noticed the app briefly going back to the home screen just after the start of the event, seconds before my Wattage disappears, so I am pretty sure that this is an issue with the Android app. Very annoyed by this, going to try with my old Macbook air and internal bluetooth next…


(Alexander McLeod) #20

I think you’re onto the issue with the Android app… Going to send in my log files tomorrow to see if support can bake anything of them.