Kurt Kinetic smart control 6400 not adjusting resistance

I’m new to Zwift and am trying to utilize my new Kurt kinetic smart control 6400 road machine. I’m using my Samsung Galaxy 10e Android phone with the Zwift app version 1.0.43801, Zwift companion app version 3.9.2 and kinetic app version 1.4.22. I can pair the kinetic device to Zwift fine and the power readings seem accurate. However I have 2 areas of concern. First is my garmin cadence sensor won’t pair. Yes I have selected the ant + feature when trying to pair the device. The second and most problematic is the controller doesn’t change the resistance when I’m ascending during a free ride or group ride. Yes, I have the trainer difficulty set at the maximum. I have used this same trainer in the Rouvy app and the controller works as it should along with the cadence sensor. I have tried turning off the BT feature on my phone and just running all the sensors on ant + but that gives me the same result. I’m stumped at this point and need some help.

Hi Craig.

At this stage ant+ is only supported for heart rate on Android.

Did you pair your trainer as power source and controllable?

1 Like

Good to know about the ant+. Yes, I did pair the trainer as power source and controller.

I have the same problem with the Kinetic 6400 model. The resistance does not increase going up hill. Was there a solution to this problem?

I also have the same problem with a rock and roll smart control T6400 , galaxy S8+. The trainer does work with zwift properly if you use an apple phone, but both the galaxy S8+ and Galaxy s6 do not work and have the same symptoms, as follows:

  1. Trainer works fine in Kinetic App workouts - ERG Mode works. And hardware test works.
  2. Zwift connects to both controllable and power with bluetooth to the trainer.
  3. In Free mode and group rides there is no change in resistance with gradient change. Super frustrating.

It appears to be an android issue where Zwift is not communicating the resistance information to the trainer properly.

Really want this solved. Any info would be great.

I am having this same issue, I am using a windows laptop connecting VIA bluetooth. Did you find a solution for this?