Kinetic Smart Control - Resistance and Road Feel


(Leo Franceschini) #1

Good evening everyone.

Recently I bought a Road Machine Smart Control from Kinetic.

The workout mode with ERG mode on works fine although power readings seems to be a little high.

The free ride mode however is not working properly.
On the first couple days on Zwift, the resistance on flats and downhills were the same and quite high. It was impossible to use harder gear, I had to keep on the 34x28. There was very little inertia as well.

Today I tried different calibration approaches using Kinetic Fit App and I thought the problem was solved since the road feel was amazing. (resistance, inertia and power readings were more realistic, I was able to ride with other riders and draft then - it was impossible before since accelerations were way off). I was able to change gear & cadence and get the same power.

When I tried to go to a steep climb to see if something changed on steep climbs and downhills, everything got messed up again.

The resistance kept the same as it was on the flats and power readings sky-rocketed. I stopped pedaling and waited to the trainer completely stop. It made some calibration noises and the resistance became more realistic as well as power readings.
Once I did a U turn and started going down, the resistance didnt change (kept high) and the great road feel on flat terrains was gone.

Tried to stop pedaling again but nothing happened.

Everything is up to date: firmware and apps.

Is there anybody else here with the same problem or a solution?

 


(Brian Hetman) #2

Leo - I have the same unit as you. While I’ve not experienced the issues you described. I did have issues with how the estimated cadence is handled. Could not get up to 110RPM’s no matter how fast I spun and would get power numbers that were opposite what you would expect for the terrain. I put a dedicated Wahoo cadence sensor on and both issues went away. Might be worth a try…


(Leo Franceschini) #3

Hi Brian, thank you for you answer. 

I´ve already tried a dedicated cadence sensor but I got the same result.

The resistance is constant no matter what. (Its the same for different “trainer levels” on kinetic app or different gradients on Zwift)

I followed all instructions that Kinetic Team gave me but nothing so far. Apparently I have a defective unit.

I hope Kinetic solve this issue soon, my trainer is basically useless and it´s very annoying.