Issues since 1/15/18 update


I have not been able to use Zwift on my computer since the software update on the 15th.  When I click on the ride button the app launches and I can hear the Zwift music in the background but my screen is all white.  I have removed and downloaded Zwift 7 times and reset my computer back to the factory settings 3 times.  I have tried contacting Zwift tech support but after 10 days they have offered no suggestions or solutions.  It’s a bit frustrating.  I’m hoping it’s a simple solution but don’t know where to start.  Can anyone offer a potential solution?



That stinks Brian!

Zwift update or Windows?

Have you submitted a support ticket?

Some ideas:

Do you get any type of log or dump file created in your Zwift folder in My Documents? If there is one, be sure to submit it in your ticket.

Make sure your graphics drivers are up to date.

I’ve been into simulations for 24 years and if I was in your shoes, and nothing else worked, I would do an uninstall of Zwift, delete any and all folders, then search the registry for any references to Zwift and delete those, then restart computer.

Load Zwift again with fingers crossed.