Issue with Smart Trainer Control on Edge 1040 and Zwift

Hello Guys,

I have been experiencing an issue while trying to control my Smart Trainer (Zwift hub) with my Edge 1040 device.
As I am not sure if this is an Garmin issue or Zwift issue, I will post it in both forums.

The problem arises when I use the Zwift app in free ride mode and disconnect the Smart Trainer’s controllable feature from the Zwift app. I then connect the Smart Trainer (as a smart trainer, not as a sensor) to my Edge 1040 and follow a workout in the Edge using Erg mode, all while simultaneously free riding in the Zwift app.

The reason I use this setup, instead of having the Zwift app control the trainer for the workout, is due to participating in a Zwift Tour Of Watopia. In this event, you earn double XP while free riding, whereas in Workout mode, you only receive normal XP.

Initially, this setup works well. For instance, if I am following a workout that requires me to maintain 200W for 20 minutes, followed by 220W for 15 minutes, everything goes smoothly. I can see on the Edge display that the power changes to 220W after the initial 20 minutes, and the resistance in the Zwift hub also adjusts accordingly. I can observe my actual power output aligning with the specified values.

However, the issue I encounter is that the Edge intermittently drops the Smart Trainer signal and then attempts to reconnect it. For example, if I were following the 220W power when the signal was dropped, the Edge eventually reconnects, and the display shows 220W under “trainer power.” I can still continue my workout at the correct power level.

The problem arises when I need to transition to a new power target, say, 240W for the next 10 minutes. At this point, the Edge correctly updates the displayed power to 240W, but the Smart Trainer fails to respond. Even when I attempt to manually adjust the power using the “+” or “-” buttons on the Edge, there is no change in the trainer’s resistance.

I’ve also tried accessing the Edge’s configuration settings under “smart trainer > set power” to change the power manually, but unfortunately, all subsequent power steps are ignored, and the Smart Trainer remains stuck at the last power level before the signal drop.

Is there something that I am overlooking? Is there a way to make the smart trainer respond again to the edge commands after the signal drops and the trainer is reconnected?