Power not controlled during a workout

First post here from a new user.

I have been riding with Zwift for about a month now on a Kickr 2018 and I am absolutely loving it. My setup is as follows: Zwift on Mac, connection to trainer is via ANT+ (Garmin USB stick), display via HDMI to TV, heart rate and cadence via ANT+ (both Garmin).

Tonight I tried to do an optional workout and I had a problem with controlling power. The ride started as normal but around five minutes in the ride the power started to cut out intermittently. Eventually the control of the trainer stopped completely and although I was in a workout the wattage was what I was putting out and not what was dictated at that part of the workout.

Both the trainer and the controllable appear connected via ANT+ as are the HR and Cad sensors. Trying the iOS Zwift app and connecting to the trainer via Bluetooth controls power normally in the workout so it must be a problem with ANT+, but the way I see it unless the ANT+ dongle can connect but still fail to send a signal to the trainer, the problem must be either software or with the trainer.

Any ideas? Thanks a lot for reading and for any help.


Are you using a USB extension cable for the ANT+ dongle? If not, I highly recommend it to eliminate or at least reduce any signal reception/interference issues.

Hi Lin,

Thanks for the reply. No, my dongle goes directly in the side of the laptop. Where would you put the dongle with the extension? Closer to the trainer, or do you mean that the laptop itself may interfere with he dongle?

Thanks again!


With the USB extension cable, I put the dongle down under my chain stays, behind the bottom bracket (to avoid sweat).

Also, if possible, move your house WiFi to 5Ghz. Your equipment may or may not already support 5Ghz. The reason for this suggestion is that ANT+ is also using the 2.4GHz that typical WiFi uses. Hence, interference due to WiFi is a possibility. If your gear doesn’t do 5GHz, manually set your WiFi to use something like channel 1 (1-5 are all probably fine) to get it away from ANT+ (channel 11 iirc).

1 Like

Thanks again!

I am on a 5GHz network and I have just been trying a few things and even Bluetooth is not working now. After persevering I managed to connect to the trainer via Bluetooth but “No signal” was displaying on the screen and I could not move my avatar…

So disappointed… :frowning:

With my Macbook, I found ANT+ works great w/the USB extension. When using ANT+, I turn off Bluetooth on the Macbook. I previously would listen to iTunes and use Bluetooth earbuds. I ended up having too many issues. WiFi and Bluetooth should have separate antennae, but who knows how they are laid out in the Macbook casing. Instead, I now connect via Bluetooth to my iPhone for music.

Two options:

  1. Get a USB extension and turn off Bluetooth.
  2. Bluetooth only. Remember that with Bluetooth, the Kickr can only be paired to one other device. Make sure that nothing else is connected to it (e.g., Wahoo app on your phone, etc…)