Power Meter w/ Smart Trainer


(Scott Steele) #1

Hey all, I’ve had some difficulty with the resistance on my trainer. Even pedaling in the highest gear, the Kickr resistance drops down to virtually nothing (please see attached photo), zwift trainer difficulty is set to 100%. Nothing else should be interfering, as I disabled Bluetooth on my phone and macbook, and my Garmin Edge device was off. Even after setting the power source as Kickr, the resistance still drops to virtually nothing (even in the highest gear). Does Zwift not support power from a dedicated power meter vs from a smart trainer? Thanks in advance.

My current setup is: 

Zwift running on Mac OS Sierra
Power source: Quarq DFour (Ant+)
HRM: Garmin HRM (Ant+)
Cadence: Quarq DFour (Ant+)
Controllable Trainer: Kickr 2016 (Ant+)


(Steve Isaacson) #2

Hi 
I am using a Quarq Riken with a Kickr 2. I control the Kickr with the PM which also gives cadence.

There may be another easier way but I managed it through the Wahoo app.

Download the wahoo fitness app.

You will then have to search for your sensors. (Bike power, Kickr etc).

Click on those. Under Kickr and bike power profile there is an option to “Control with ANT +Power Meter”.

Slide to on.

Try it now. Your PM should be controlling the smart trainer and the power should reflect what you are putting out on the road. I have my Garmin 1000 on occasionally and my power reading on my Garmin directly from my PM is the same as on Zwift, so hopefully it is a more realistic assessment of real world power output.

If you have a PM  running your smart trainer this way avoids the aggravation of an under or over- reading smart trainer power, and your W/kg is probably more accurate than the riders without dedicated PMs. May make you a bit slower than those with less accurate power readings though!

Hope that helps.

 


(Tom Hewitt) #3

This is really helpful Steve, my only question is, does the Wahoo Fitness app need to be running a workout simultaneously with Zwift or does the “control Kickr with PM” settings change the setting on the KICR permanently until changed back. Thanks in advance.