ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

FWIW, just received the following communication from support. Not sure if boilerplate, but hoping resolution is soon.

*At this time this is a known issue with Zwift. Our team is working on a fix. While there isn’t a work-around for this issue as of yet, the fix will come from our end and all you should have to do is keep your Zwift app up to date. If you are able to use a different supported device while we are working on a fix that would be great. To see our supported devices you can visit our Support Site here . This issue is only affecting PCs and Macs at this time so if you have a supported tablet or mobile device that would be ideal. While I know this isn’t what you wanted to hear, I can assure you our team is working on getting this resolved so you can get riding again how you usually do.
We appreciate your patience and understanding as we continue improving Zwift. Please let us know if there’s anything else that you need assistance with; we’d all be more than happy to help!

Erin R.

fingers crossed.

None of the above mentioned workarounds worked for me so I guess I’m waiting on the Zwift team. Seems odd that they haven’t updated more in 9 days of knowing about an issue.

I spent hours on this and could not work out what was going on. Eventually found a fix after re-imaging the NUC twice, uninstalling and re-installing many times. It turned out to be something else and used a VPN to get a connection from the WLAN. Deleted the documents folder and then re-ran the installer and finally it worked.

why the patcher.cpp does not work and requires a VPN to do so is beyond me as definitely not a permissions issues as suggested.

5 hours wasted but fixed.

I also spent hours on this. Finally got it working by re-installing on a new folder x86/zwift2 and also using a VPN to grab the update

I was also getting this error on the last update. I downloaded/reinstalled/deleted/tried phone hotspot, messed around with the firewall etc etc etc. Eventually had to take it to someone else’s house for different wifi and it worked.

Now there’s another update, launcher is 1.1.1, and I was getting the same Z117 error at line 602 just now (was 601 before).

The comment from @Kris_Matthews worked for me - I used a VPN to download/install the update and it worked the first time. I didn’t have to delete or reinstall Zwift or anything.

I see the Vodafone comments above and although I’m not on that carrier, I use Telus 4G in a LTE modem to supply my internet, and my phone is also Telus. Wondering if the issue is related to how our internet is supplied.

Thanks for this James, Tethered to my phone and also worked straight away after getting repeated Z117 errors that were not fixed by any of the workarounds suggested on the Zwift support page for this issue.

1 Like

Hi All,

Looking for some help. I am trying to install the latest zwift update but keep getting error code z117. I have uninstalled zwift and re-installed then tried to install the update but still no joy. I have also contacted my antivirus software support team and they say its not anything being blocked by them.

Any help would be much appreciated. I am pulling my hair out as I can’t open zwift until it is resolved.

Many thanks in advance


Hi, after the lastest update I have , AGAIN, the dreaded z117 error message when launching Zwift on PC. It first appeared 3 months ago right after every game update. Each time a fix was provided which solved the issue and apparently a definitive fix would solve it for good, but it’s here again. I went through the whole unsinstall process again but nothing helps. Please fix this for good once and for all…

Z117 error has returned here too… after a recent update had fixed it. So for now it is back to either:

  1. Tether your Zwift device (PC, tablet etc.) to a mobile phone hotspot instead of your normal home internet connection.

  2. Or disable any “Web Content Filter” type features of the firewall/home internet security solution you have.

Let the update finish, then revert back to your normal setup… until the next patch :roll_eyes: At least I have re-entering Zwift login passwords every time I load Zwift to keep me occupied :face_with_raised_eyebrow:

I am another who is suffering this same update issue when updating from home. I took my laptop into work today and it updated first time. Come on Zwift Support, this should surely be fixed by now. Zwift has been updating fine until the last few months.

I had been getting this issue since the latest update in Feb 2022. After reading a few of these posts it occurred to me that my VPN could be the issue. I disabled the VPN and it installed right away without the Z117 error.

1 Like

Having issues with the latest update! Was getting error z117 at line 602 in patcher.cpp. Worked with support to get it working with no luck. Was going to drop my membership and when I turned the computer today it downloaded the update and did not give me the error. I started Zwift and it ran fine. This is weird! I did nothing to the computer and now all the sudden the update worked. This happened with the previous update also! It would not update and gave me that error, then a few days later it updated! Could this be their servers and the amount of updates being done? I hate having to wait days later for it to work.


1 Like

I am really over this. Got around it lime after many days of trying to have it reoccur with the next update. No other program seems to have a problem except Zwift. Thinking of going with an alternative now. Bloody annoyed.

AAAAAArghhh. That is it, I’m cancelling membership. This is a farce. I haven’t got the time to reload then sit with fingers and toes all crossed hoping that the programme works. It worked for the last two years without a problem now since November its been an absolute shambles. Downloading this downloading that, copy and pasting folders into different folders, uninstalling and installing. GET IT FIXED ZWIFT. IT IS NOBVIOUSLY YOUR PROBLEM. JUST LOOK AT THE NUMBER OF COMPLAINTS.

1 Like

Looking at the first post it seem like it is a Network ISP issue when people change to another network every thing seems fine.



I have ridden Zwift for years and this problem has only started a few months ago. As others have said this is only happens with the Zwift program, not other s/w. Come on Zwift we pay good money to ride with you, please get this fixed.

1 Like

Same problem for me. I’ve been trying to update Zwift for almost a week. Same error every time. I tried to uninstall, turn off anti virus and other things that could help but nothing helped. Very annoying.

1 Like

Not here unfortunately

Have you managed to sort this Jim. I haven’t been able to ride for the last three months with the same problem. Tried all the stuff on here to do with copy/paste, uninstall/reinstall, using different providers!!!