ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

Throwing my sad hat into the ring. Man is no fun playing for something I cant use…

Yeah, a frustrating experience, esp if you’ve spent $$$ on a dedicated PC / graphics card. And all communication from Zwift support was canned response. Very disappointing, especially when the issue seems to fully go back at least a year, based on searches.

Meanwhile, kids were none to happy with my borrowing their iPad. :wink:

After the initial reinstall / failed update, I ended up tethering to my cell phone’s hotspot to try the update. FYI, here in CT USA, using Optimum for ISP, Verizon on cellular. Limited data plan, so was worried about data usage, but (IIRC) in my case it was only 1-2 hundred MB total…was worried it would be GBs worth of data. The ‘wonky’ content distribution network Zwift’s using seems the best explanation to me.

I saw others physically took their machine to work to run the update, seems crazy but desperate times…

That was last month. This month’s update completed normally, FWIW.

Good luck everybody.

What internet provider are you using for normal Zwift.

Surprise surprise a new update gets released 13Th April and the good old z117 Patcher Line 602 or Line 601 error is back. Seems to me that Zwift have 2 updaters that are being used. One that’s stable and one that isn’t. Each monthly update that is released is via one of these patchers.

NEWSFLASH - SORT IT OUT ZWIFT. You have enough people working for you to be able to rewrite the code to a cleaner version. It’s a mess!!!

Same issue for me, another update and Zwift update seems to be broken again with Z117 error after working the last few updates. Come on Zwift, surely you can assign resources to this and get it fixed once and for all. This is not what we pay for.

Any update to this issue? I’ve just run into it for the very first time today (15 Aug 2022), Googled the error codes and found my way to this forum & thread only to find that it’s been lying around in one form/version or another for months and months.
Is this really still not fixed?
Have I missed something? The thread seems to stop on April 16 2022. Did others find a reliable workaround?

The issue still is not fixed. For me some updates work, others don’t - the latest update hasn’t worked My workaround is to bring the laptop into my office. When I use the office connection it updates fine. All very strange as Zwift updated for years without problems until about 6 months ago.

Just 1 more datapoint, though not conclusive…
I read through the whole thread and often seemed to find Vodafone ISP hanging around at the crime scene - though not proven guilty/accomplice, but often curiously lurking at the scene.
I was using Vodafone as a mobile 4G/LTE ISP provider and found this problem for the first time after starting to use Vodafone, within the last 4-6 weeks, ie this might have been my first major update since switching to Vodafone.
Today, I had the opportunity to use O2 4G/LTE and did a complete re-install with O2 and…it worked.
It’s not conclusive I know, but it’s 1 more datapoint and might at least guide other folks towards a (temporary) alternative way to get back up and running…for a while at least. Try not using Vodafone as your ISP if you can.
C’mon Zwift, get this sorted. There’s enough meat in this thread alone (and others) to tell you that it IS your problem and/or maybe that of a major (UK) telecom provider with whom you have definite (combined) problems.

Exactly the same here: Update or Re-install using Vodafone 4G fails with error Code Z117 at line 602. Using BT Broadband works…

I had to reinstall the OS on my Windows 10 laptop. After that I attempted to install Zwift but get the z117 error. I tried as admin, Documents is not synced etc. The app starts and then says it needs to restart for an update. When it restarts, I get the error message. Not sure if anybody at Zwift is reading these forums but I guess this is just my upvote for a fix for this (I have successfully installed many other apps on the PC). There have been several other issues with the PC version. I usually need to restart my PC after updates for instance (hmm, I haven’t tried that yet for this issue. BRB.) Thanks!

No luck! Still the same message. There was another screen that flickered just a short while with what I presume was another error message but it only showed for a fraction of a second. And I’ve tried different ISPs too.

same here- i know my isp sits on the vodafone infrastructure. its absolute garbage that i cant use the software more than 25% of the time after a tiny patch

Same with me. Just set up a new Direto trainer, which was supposed to be a relatively easy task, according to all the online reviews. Turned out to be quite the opposite. I spent a long time fiddling with the rear cassette, which still doesn’t really work how I imagined it would. The Ant+ was a relative pain to install as well, but managed to set it up after some digging around online. Couple of hours later and I’m writing this to complain about an error many people seem to be having, but no one has been able to provide a solid answer.

I managed to set up Zwift on my phone in a matter of minutes, but I can’t get over the Z117 error if it kills me. Tried many of the so called workarounds, but nothing seems to work and I get the same error message every time.

Hello Arto. I have the same exact problem, also tried same things. Have you managed to find the solution?

In my case it was a Swedish character in my user name that ended up in the file name (path) that the installer couldn’t handle. I had to add a new user with only a-z characters in the user name and install Zwift for that user. Hope this helps. Ride on! -Arto

this error is still happening on the latest update 21.12.2022, surely a permanent fix should have been put within the system already to stop this error constantly occurring.

Wow, good job figuring that out!

1 Like

Several similar issues recently. The game as a whole is clearly very sensitive to this stuff, so if you don’t install everything absolutely as it expects, things go wrong. There was a thread the other day where someone had adjusted the path when installing the game and it totally ruined the graphics. I know of at least one person getting crashes because their My Pictures folder was pointed to a different drive than C: (reverting it solved the crashing).

All of which is ridiculous, frankly.

I have this error with windows 10 64 bit , i have tried everything but i still doesent work…

What have you tried so far? Have you connected your system to a different network, such as by tethering it to your phone or using some other source of Internet access? Tried removing and reinstalling Zwift?