ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

[SOLVED - Update a few mins after posting this: I tethered my PC to my mobile phone and Zwift updated successfully. I can now login/enter routes using game version 1.0.100133

I’m guessing my ISP or the CDN in my region may be have issues and are corrupting some of the update file downloads]

Hi, I cannot apply the update for Neokyo as files are not downloaded properly - Is this a CDN issue? . . .

Set-up:

  1. Running Zwift on Windows 10 64-bit (clean OS/Zwift install 3 weeks ago, been running fine).
  2. Login account has local Admin access. PC is only used for Zwift, so just running vanilla Win 10 + Zwift.
  3. C: has >> 4GB free space. 8GB RAM, 3.7GHz Intel i3 CPU. Nvidia GTA 1050 Ti GPU.
  4. 5GHz Wi-Fi with strong signal to access point.
  5. In the UK, ISP is Virgin Media 55Mbps download/ 20 Mbps upload.

Problem:
Ran Zwift yesterday evening (18th Nov 2021) and it tried to apply the update for Neokyo, which failed with

Update Failed during patching: Error Code: Z117 at line 601 in Patcher.cpp

I tried the usual things like clearing browser (Edge) cache, rebooting, different login to PC . . . same error. I ended up de-installing Zwift, downloading the installer (“Launcher Version Number 1.0.52”), after initial install Zwift tries to update and it is back to the same “Z117 at line 601 in Patcher.cpp” error.

Diagnosis:
Looking in \Documents\Zwift\Logs\Launcher_log.txt I can see that some files are not downloading properly; either as 0 bytes, or the wrong number of bytes (see below). I have tried again this morning and same behaviour, but different file . . . Does Zwift’s CDN have a problem?

18th Nov - ShisaStatueGiant.gde 0 bytes:

[21:58:06 2021-11-18] Patcher: “C:\Users<my account>\Downloads\Zwift\data\Environment\Level Design\Tropics\ShisaStatueGiant.gde” file verify failed – File sizes differ. Passed=52186, Actual=0.

[21:59:01 2021-11-18] Patcher: Kicking download of missing local files from server…
[21:59:01 2021-11-18] Downloader: Failed to create file handle for “C:\Users<my account>\Downloads\Zwift\data\Environment\Level Design\Tropics\ShisaStatueGiant.gde”. Error code: 32.
[21:59:01 2021-11-18] Patcher: ERROR #Z117, FILE “Patcher.cpp”, LINE 602: Failed to download needed server files for update! (Last: “”)
[21:59:01 2021-11-18] Launcher: ZwiftApp.exe is not running.

19th Nov: WhiteOrangeTheme.wad Passed=1842055, Actual=1841468

[7:37:03 2021-11-19] Patcher: “C:\Users<my account>\Downloads\Zwift\assets\UI\WhiteOrangeTheme\WhiteOrangeTheme.wad” file verify failed – File sizes differ. Passed=1842055, Actual=1841468.

[7:38:26 2021-11-19] Patcher: Kicking download of missing local files from server…
[7:38:26 2021-11-19] Downloader: Failed to create file handle for “C:\Users<my account>\Downloads\Zwift\assets\UI\WhiteOrangeTheme\WhiteOrangeTheme.wad”. Error code: 32.
[7:38:26 2021-11-19] Patcher: ERROR #Z117, FILE “Patcher.cpp”, LINE 602: Failed to download needed server files for update! (Last: “”)

I had exactly the same problem. I’m in northeast US. Luckily was able to do the same, tether to my iPhone hotspot and update through that rather than my cable provider.

Note, the error occurs on multiple computers, so I believe your suspicions are correct - it’s something to do with the internet provider, not local to your machine or configuration.

2 Likes

Exact same problem here in the UK - I haven’t been able to ride since the last update with the new map :frowning:

Same problem g first installation in Italy

Logged the issue with Zwift Support but apart from recycling the standard troubleshooting steps from the knowledgebase / support pages they have so far being less than helpful. They don’t appear to know what a CDN is! :smiley:

Needs someone from their 2nd / 3rd line tech team to investigate the files on the CDNs as it is likely their is a corrupt store somewhere…

I’ve managed to successfully update my laptop using a tethered mobile connection and then manually copied over the missing files to my desktop PC (into the Download folder that the zwift updater had created). These are the main files that consistently fail to download, taken from the log file.

“data\Environment\Level Design\Tropics\ShisaStatueGiant.gde”
“data\Environment\Overpasses\Overpass_Norm.tgax”

This is a workaround to complete the update but is far from ideal. I’m amazed that the updater appears to download each file individually in an uncompressed format.

It is consistent in that the majority of the files are downloaded successfully and always fails on the same files which is what led me to believe this could be an issue with the file repository. So far I’ve worked out that for me cdn . zwift . com is resolving to 4 load balanced cloud front servers. The IP addresses for these change periodically (which could explain perhaps how some people didn’t do anything apart from reboot or try and update at a different time).

I did attempt to manually download the missing files as the location details are all contained within the log file. However I’m unable to manually download files from the file server apart from the version XML file as the other files appear to require authentication to download (403 error).

I’m wondering if cloud front is closing the connection at some point during the download for some reason but I guess no one really cares. Unfortunate for anyone who isn’t technical and is faced with this issue as they will likely just not ride and/or stop their subscription.

For anyone else with the problem you will probably have to download (by running the installer) the missing files reported in the log file through another internet connection (perhaps on another PC) and then copy them across to your desktop if required like I did.

2 Likes

New release SAME PROBLEM!!!
Has anybody come to solution??

Try updating while tethering to your mobile’s data connection.

Hello, same for my 2 laptops cant download the magic file.
ShisaStatueGiant.gde

anyone could provide information on this file ? size ?

EDIT : modile data connection doen’t solve my issue

Same issue here too. Tried two different laptops, also tried via mobile phone tethering - no luck. Will have to resort to iPad until resolved.

1 Like

Thn youuuuuu SOSO MUCH STEVE!! But what is the REASOn?

As I understand it, sometimes downloaded files are corrupted or incomplete, so they fail an integrity check, and the patcher cannot complete. Changing the internet connection forces the file(s) to be downloaded fresh, rather than from a cache.

Edit: as explained by @David_Knight4 above.

Replying to my own topic to add to the list… New patch this week had the same error. Again Wi-Fi tethering PC to mobile phone hotspot allowed Zwift to update.

Okay, so we have a workaround, but why is this happening? My home broadband lets multiple PCs, mobiles, games consoles etc. download files from the internet all the time without any problems . . . except for Zwift :frowning:

How do we get this on Zwift’s radar to investigate/resolve?

Have tried again and again, same problem. Have also tried the suggestions Zwift support offers on their website, to no avail

I’m getting the exact same error message. Tried tethering to phone, hasn’t worked. Any things we can try?

2 Likes

Hi Dan,

I have the exact same problem since the November update on November 18th. Been in contact with the support service a number of times, but have not yet been offered a suitable solution. Tried to email the support service again 3 days ago, but they don’t even respond to my email anymore…
I fear that this is a problem that Zwift itself does not know how to deal with.

Look up one post, give that a go. Alternatively tether to your mobile (using 4G) and try the update again.

1 Like

Post above doesn’t work for me. Already tried it. I can trie the phone alternative. Maybe it works. Thanks Dave.

1 Like

I have the problem that after a period of time sometimes 30 minutes sometimes shorter Zwift screen blanks out and windows says programme not responding, has anyone else had this please and how did you fix it