Is anyone successfully running a KICKR Core with latest firmware update using Windows 10 over Bluetooth?

Ever since upgrading to KICKR CORE Firmware v1.0.12, Zwift can no longer find the KICK core. It finds the Power Source, but says no connection. iPad works OK. I rolled back to v1.0.10, that fixed it. Wahoo said they fixed the firmware so when going back to .12 it stopped working again. v1.0.10 is no longer available via the app. Wahoo is now saying they don’t officially support Bluetooth over Windows devices. They are recommending using ANT+.

Anyone with similar issues?

Yes i also have the same issue, cannot connect on zwift android tv since this last update.
How did you downgrade the firmware?

I’ve was given the following. Just be aware that the working version of the firmware isn’t available. Also log a ticket with Wahoo. I’ve got a support ticket open requesting the working firmware be made available again:

Android Steps

  1. Open the Wahoo Utilities app app.
  2. Make sure the Wahoo device is powered on.
  3. Click on the Wahoo device when it pops up.
  4. Wait for the Wahoo Device to connect, once connected tap the grey icon of the device with the Bluetooth emblem in it 10 times to bring up the firmware update list. It will show what firmware is current, choose the latest firmware next to that update in the listor the one that is (recommended).
  5. Allow the update to finish and try and reconnect the device to the Wahoo Fitness app when done.
  6. Return to the Wahoo Fitness app, repair the sensor in the sensor settings and save the sensor to the proper workout profiles.
  7. Return to the main wahoo fitness screen, select the proper workout profile and start your workout!

IOS Steps

  1. Open the Wahoo Fitness app.
  2. Click the sensors icon on the bottom left side of the app.
  3. Click On the device if it is saved, find a new sensor if it is not saved.
  4. Click on the Wahoo device when it appears and wait for it to connect.
  5. Click the grey device icon with the Bluetooth emblem in it 5 times to bring you to the firmware update screen.
  6. Click on the recommended update or the downgrade to the current update you are using.
  7. Once complete, go back to the sensors page,save sensor to the proper profiles.
  8. Return to the main screen, select workout, and start your workout!

Thx it worked, got the firmware 1.0.10 again can connect now.

I recently installed 1.0.12 which from the Wahoo firmware page says fixes this issue, BUT since installing this update, Zwift can connect via windows 10, but I get “No Signal”, hard to know if the issue is with Wahoo or Windows 10 updates, the bluetooth all seems a bit flakey.

I tried to follow the above to downgrade the firmware on iOS, but I dont have the Bluetooth emblem mentioned in step 5?, least I cant find it, Im connected to the trainer.

The instructions are a bit misleading, as I couldn’t find the icon either. If you tap the sensor name 5 times it brings the firmware list. Be aware the working version was removed. I got Wahoo to add back on. Not sure if it’s still there though.

Thanks, try as a might I cant get any firmware list to appear,

You able to post a screen shot of where I should be pressing?, just to make sure im actually pressing in the right place, im x5 pressing pretty much everything !

Im on iOS

I don’t have access to my kickr for another week but I think you tap here 5 times. It should then bring a firmware option. Took me a while to get it right last time. Let me know how you go.

Brilliant, got it in the end.

Have to have the right tempo for the 5x pushes, not too fast not too slow

Have downgraded to 1.0.10 and Zwift via windows is all working again.

Many thanks

Just downgraded from 1.0.12 to 1.0.10 - kickr core fried, no power lights etc. Super upset.

Just buy an ANT+ stick and all problems are gone.

I have wahoo fitness version 5.36.0 on ios.
I didn’t succeed in tapping five time.
Maybe in the last version of the application thats doesnt work, do you know if there is another option?