iPad Pro issues


I have been set up on Zwift with Wattbike Atom, iMac (2012), ZC app on iPhone and Garmin Dual HRM for a while with no problems. Used an Ant+ dongle.

Just got an iPad Pro and all connect via BTE on the connection screen. However, when doing a workout using ERG mode, there is very high resistance to start (often barely able to turn pedals) and once going, the control of power levels is all over the place. Frequent power spikes, drops and cadence very variable.

I have removed anything else BTE and even tried without the fan nearby but no change.

Any ideas what to try next?



So just to update. I had a play around this evening with Zwift on the iPad Pro. I think by doing a few tests I have narrowed down the issue a little.

I noticed that my cadence reading was quite variable (despite pretty constant pedalling) which I thought may be triggering random changes in resistance.

I switched off the wattbike and then did a test ride with erg. Initially resistance low (as is should have been). The same sporadic power was then seen. I disconnected the cadence sensor and reconnected it. The cadence then seemed smoother and the power spikes settled. This was shown in the cadence image attached. The little cadence spikes are not real in the first half.

I then tried another ride. I hadn’t switched the wattbike off - just set up another test ride with erg. Resistance really high at start so immediately disconnected and reconnected cadence (and I think controller) and issue resolved.

Whilst this is a workaround, its not one I want to continue with - any ideas??



what workout are you doing, ive had the oscillating power output happen after an ERG stop and restart , it then corrects itself after a workout target change.

Hi - thanks for your reply. I’ve experienced the problem on TP imports, Zwift workouts and Zwift custom workouts. The common factors seem to be ERG mode and bluetooth. Its fine if I use ANT+ on the desktop or do a free ride on bluetooth.

I have toggled it on an off to try and sort the problem without consistent success. The most reliable way I have found to correct the issue is to disconnect the bluetooth and then reconnect them - but even that isn’t 100% reliable.