Ipad crashes after finishing and starting a group ride (latest app version)

I’ve been riding multiple group rides in the past months and after finishing them, the data got processed and saved without issues.

I recently updated the Zwift app on my iPad to the latest version and now the app crashes whenever I finish a group ride. Data starts processing and then the app crashes. Luckily the ride was still saved (but not the map data) and I can continue it, but due to dropout I can’t continue riding with the people from the group ride.

This crashing also occurs when joining a group ride. It can take up to 2-3 times before I’m able to join the event group ride. This has caused me to miss the first 5-10 minutes of the previous rides. Luckily late joining was possible or I would have not been able to join the group ride.

A few rides later, frustration and testing different scenario’s it looks to be something with the new IOS iPad update and perhaps older devices as well, as my iPad is a Mini2.

Tuesday: tried joining an event -> took 30 minutes of crashing etc before I tried with my iPhone which worked flawlessly
Wednesday: tried joining the TDZ ride -> upon joining the event the app crashed so I moved again to Iphone
Thursday: doing a regular ride on iPad -> all ok, however, when joining an event, it again crashed and again had to use my iPhone

Is this an issue of the latest iOS app version? Or my old iPad Mini2 not being supported any more (although still mentioned like that on the site)?

There have been a lot of iPad crashes reported here recently. Whether it’s something specific in the latest Zwift app version, or maybe affecting people running on older versions of the OS, it’s hard to tell.

Ive had this, same story, ipad air running 12.4.9, i also have issues with notification saying that bluetooth devices user battery power or something even though the app is closed and ive used the close app slide up facility.

I did delete the app and reinstall, which seems to have potentially made it more stable.

Thanks for the advice.

I’m now running the latest app version and seems more stable.
I doesn’t take so long to log in and I’m able to do individual rides.

However, the app still crashes on event rides!
So for the recent TDZ rides I had to revert back to using my iPhone :frowning: