Zwift crash when crossing finish line

Hi. I have read this problem in these forums, but I’m yet to find a fix.

My sessions crash almost every time I cross the finish, both on TDZ rides and other group rides.

I’m running Ipad with IOS version 12.5 (just updated to 12.5.1 which I’m hoping helps). I’ve never had a problem running with the same Ipad for the last 3 years.

Has anyone found a fix for this yet? I’ve tried the re-install of the software, without any improvement.

Also, I rode TDZ stage 1 twice, with the crash at the finish both times, and I’m still waiting to be credited with the stage 1 finish. Is anyone at Zwift support able to sort this out?

Regards, Phil

Sounds like an old iPad.

Might want to upgrade to a newer iPad that can run iOS 14.3

I also had this problem on TdZ Stage 3. Seems like something ZwiftStaff could fix, since my feed clearly shows the route completed and I even rode it with a friend that did get credit. Still waiting to hear.

1 Like

I see it a definitely a Zwift issue. My i-pad isn’t the newest, but it only gets used to run Zwift, and its been fine the last couple of years.

As you say Tom, I don’t have any issues during the ride, only when I cross the finish. Its as if there’s a bug that stops the data upload, and then it just boots you out when it cant upload.

Its easy to prove that it was a TDZ ride, as its start time matches the TDZ start time. I even have the email congratulating me on the stage 1 finish… but no stamp on the start up screen.


Concur on all points. Probably some poor employee at ZwiftHQ that gets stuck with all these “fix my TdZ credit” requests. Looks like there are lots based on search.

Unfortunately I’m having this problem too running IOS 12.4.9 on my iPad. I did TDZ Stage 1 and it dropped out as I crossed the finish line. I did Stage 2 & 3 on an Apple TV without issue. Again today using the iPad on crossing the finish line it dropped out again I rejoined & continued the ride & saved it - but only have ‘Watopia’ on MyZwift - despite getting a congratulatory email & the ride listed in ZP a TDZ Stage 4! Also I don’t have a stamp on the menu page. Who do I contact to try to get these events reinstated?

1 Like

Hi guys,
this is a big issue. I am having this issue too, as well as tons of other riders.

You can find the thread where Zwift has merged the complaints about crashes with the iPad with the title (as it is not possible to copy the link):
zwift broke down directly after finishing stage 1 stage not completed

Unfortunately, no feedback yet with a solution

1 Like

Update: mine got patched ! Kudos to the fixer at ZwiftHQ. Thank you.

1 Like

Great news. I just checked, and there is a newer release than I have on the i-pad also. I’ll update and see if its fixed the problem over the weekend.

1 Like

TDZ stage 4 - same issue for me, crashed after i crossed the line and saw the banner drop.

Stage 4 autofilled the save screen, then ‘unexpectedly quit’ error.

Hopefully i can get the badge and dodge having to do it again.

Approx 1hr 6min completion

The same thing happens to me with Windows 10 and SPANISH language selected, at the end of an event and crossing the finish line the simulator closes and does not save the activity session, however selecting the ENGLISH language does not cause the problem, it works perfectly.
The January 22 update has not fixed it, the problem persists.
Please check it


Después de una marcha de 3 horas, se cierra sesión sin guardar los datos. Es el mismo problema de siempre. No lo resuelven, todos los españoles, deberíamos darnos de baja, somos unos cuantos. Lamentable.

experienced the same crash. 17 rode in a meetup. 10 experienced Zwift-crash when they click save&exit.
and we saw the finish line twice (one at originally-set 38km point and one at 37.3km)


And happened again - now 3/4 TDZ stages crashing when crossing the finish line. Major bug!
From stage 4 de’Huez they even send gratulation email and then later credited after I complained

1 Like

Same issue here. I just want to piggy bag here to hear from zwift support

1 Like

Update. Stage 5 TDZ didn’t crash over the finish line! However it was in Richmond, so wasn’t a busy map. I’ll try again on a busy Watopia, but hoping the update has fixed the problem. Also, support have credited me with the stage 1 finish now.

This just happened to me, and I’m using a MBP running High Sierra (10.13.6) and the moment that I crossed the finish line, it crashed out. And, when I re-launch the app on both my computer and my iPhone (Companion), it still shows that I’m still “in session,” with no way of quitting it.

ETA: I tried to upload the files manually to Strava, only for them to be rejected because they are “malformed”

ETA 2: I attempted to see if the activity uploaded to the Zwift Activity Feed, and it did, but when I clicked on the activity, it only gives me a blank page.

Another update… The problem was not fixed with the latest update.

On a busy Watopia ride (The Geraint Thomas ride), which has almost 2k riders, the session crashed out at the end of the ride.

Disappointing as it meant I didn’t unlock the ride kit.

Its getting to the point now where its a big enough problem to warrant looking at other virtual ride software. Nothing more disappointing than crossing the finish line and crashing out. Its ruining it totally for me.

Sort it out Zwift.

I too have experienced this. Zwift please fix.

Happened again today on stage 6. Crossed the line, see the finish confirmation on screen , then it goes black. After crash, system does successfully reconnect user session and saves ride, but doesn’t credit ride as TdZ completed stage.