Invalid username or password

Had to create a new account just so I could post. My zwift account has been giving me “Invalid Username or password” since last night. Have requested password reset multiple times and no mail coming through. Yes I have checked my spam filter. Extremely frustrating as I know for sure that I am entering correct credentials. I have raised a ticket but the response won’t reach me in time to let me have a ride tonight. Opportunities for me to ride aren’t plentiful. I am posting here to try and establish whether other users are having the same issue

I have a couple thoughts.
is there any spaces before or after the user name or password?
Caps lock on?
Number Lock on?
Sometimes it’s the function key that is causing the issue.

I am a network admin and I see a lot of issues like this.

Let’s see if we can get @Vincent to assist you.

1 Like

Hi Paul,
Have tried on 3 different devices and made sure it’s not case or spaces

I am having same issue!!! Very frustrating. Could someone please help or resolve

Happened to me this morning on the companion app. Had to reset password. Everything worked after that. Strange because the same username/password has worked perfectly for quite a while.