INEOS The Kwiatkowski Workout issues

INEOS The Kwiatkowski Workout issues
All riders on screen bunched over the top of one another, riding in bushes, over spectators, riding sideways, through hard objects like boulders, bridges etc … and movements were really erratic and jolty.
Some riders mentioned on messages their ET was way off, ERG wasn’t working for some also.
This occurred for the entire duration, 42mins.

Still completed it, and had a joke with the other riders on messages …
Of the many workouts i’ve completed this is the first time i’ve seen it so buggy.


Hi @Tony_A1

As I understand it, this is the kind of issue where our team will almost certainly need to examine your log files if we’re to properly understand what happened, and offer any kind of meaningful explanation.

If you’d like to contact us, you can reach us here.

Please also provide all the log files from your ride, and you can find instructions in this article.


Same for the Teo workout 7pm (GMT) Monday - via a PC.
All Ineos workouts have done that to various extents but on New York it was pretty stupid as spent more time off road than on it.

1 Like

I rode at this event.
INEOS Grenadiers Virtual Training Camp Week Five)

The start seems to be TT. (I tried to take a screenshot, but I couldn’t make it in time.)
I couldn’t run normally with a rubber band. (Very crazy)
Ride speed repeated up and down violently. (Very sick)
Maybe the route I took wasn’t “Gotham Grind”.
Some were running backwards.
What’s happening?

Hi @k.kanai

Based on your description of the issue, it seems like a buggy event, which to my knowledge sometimes happens in Zwift.

If you want our support team to investigate, my advice to you is the same as it was for the OP, send us a support request with your log files.

ok. Nearby riders had the same bug.
Is it just a bug for this event?
I’ll probably never ride this event again, so I’ll just report the bug. But there are still many events with the same event settings. Participants in this event may be affected by the same bugs.

Had some similar issues in the Geoghegan Hart workout yesterday afternoon. Instead of starting in a pen as we usually do, we started on the side of the road in various places. When the workout started, ET didn’t start from 0:00 but rather included any warmup that was done before the start of the workout. For me, ERG didn’t seem to be working for the first few minutes, but it kicked in a bit later. We also had riders riding all over the side of the road and on the grass etc. It was also the most manic rubber banding I’ve ever seen in Zwift, with very erratic movement. You could hardly see what speed you were doing as the speed was constantly changing over a large range. Hope nobody suffers from motion sickness :slight_smile: .

I’m booked to do the Kwiatkowski workout tomorrow, so hopefully, if it was just a single workout glitch, things will be back to normal.

All the same issues here for yesterday’s 1700 GMT Kwiatkowski. In addition, during the ‘freeride’ section of the workout all resistance on the trainer disappeared - it felt just like someone holding the rear wheel off the ground. Its supposed to switch to Incline isn’t it? It finally did that after the next part of the workout began, which was a 60-second cooldown. I left the event as it’s clearly messed up, but would the .fit file still be any use?

Hello, I’ve tried the Geoghegan Hart group workout the last 2 days and had to abandon both times due to issues as mentioned by previous posters ie riding on the verge, into trees/bushes, all riders glued together etc etc. Not had this before on any group workout incl the other Ineos ones. From the chat going on there were lots of others experiencing the same issues. Thankyou.

@SteeleySteele @Tony_A1 @John_Sanderson_7330 @Clint_Wilson @k.kanai

I see here that an issue was previously flagged up a few weeks ago about the INEOS Training Camp group workouts not loading.

It’s unclear to me if this issue is all encompassing the various different issues/bugs you’ve each reported happening during these events/group workouts, but I’ve reached out to a higher technical authority of the team to get more information. Thanks for your patience while I look into this!

Adding on to this that tonight’s Geoghegan Hart workout (1900 UK time) event was also bugged like described above.

We all started on the side of the road, not in a pen.
I saw at least one rider appear to start facing backwards on the other side of the road.
The pack dynamics was forcing all the riders to bunch like @k.kanai showed in his screenshots.
In the main bunch with how all riders were being pushed on top of one another the churn was awful.
There were a few ‘other bunches’ of riders way up the road away from us and the ‘rubber band effect’ didn’t pull us together.
At one point a group of riders ‘passed us’ going the opposite direction on the road.


I had a similar problem with the Kiwiathowski workout yesterday. The first time when I joined I wasn’t at the start location and the second time I was in the correct location but no workout loaded.
I contacted Zwift and they said to delete the companion app and Apple TV app and reload them. I did this and it all seemed ok.
However this morning when I did the workout I was in a different location but the workout loaded. I did it all on my own. Although somebody in the main group gave me a Ride On!
I hope a solution can be found!


Exact same issues as Kat on 2100 uk ride, on android tablet. Horrible rubber banding made watching the screen impossible as riders lurched forwards and backwards. In the end I turned off my network connection and rode the workout offline, alone, joining at the end.

Hi @Tony_A1 and everyone who reported these issues,

I’ve heard back from the team and confirmed that there’s a bug report that’s been written up for these issues. This is with Zwift’s developers now, and thanks again for reporting this!