I don't see workouts - list is empty


(Sascha Egerer) #1

If i open the “Select your workout” dialog the box on the left is empty with a grey background. I would expect that there will be some workouts out of the box. I can create a workout by myself but thougt there are already some workouts predefined. Or am i wrong and there are not workouts by default?


(Jon Mayfield) #2

Sascha, there should indeed be a substantial library of workouts available. This one is probably good for you to open up a support ticket for, and if you can, attach the log.txt file from your Documents/Zwift folder.

In the meantime, I wonder if an error occurred during the initial download that caused the workouts package to become corrupt or missing.   An uninstall and reinstall of Zwift may resolve that if so, but I have to say this would be the first time I’ve heard of workouts being totally missing.

Sorry for the trouble.


(Sascha Egerer) #3

Hi Jon,

i’ve yesterday removed everything and reinstalled again (about 600mb). Still the same problems… No workouts in the list…


(Jon Mayfield) #4

Ok, very strange.  Can you send in your log.txt and launcher_log.txt file in a support ticket?  It might tell us if the workouts exist on your harddrive, and if there were issues loading them.

Support ticket link: http://bit.ly/ZwiftSupport

Also, can you take a screenshot of what you see?  The cmd-shift-4 OSX shortcut will let you save part of your screen, or you can try “F10” in Zwift to save a shot of the workout selection screen.  

 


(Sascha Egerer) #5

I’ve checked the log file and there is indeed a problem while loading the workouts.wad.

I’ve also found the problem. The file is stored under assets/Workouts/workouts.wad. But as noted in the log file the Zwift app tries to load it from assets/workouts/workouts.wad (look at the lowercase w).

So the problem is, that Zwift does not support case sensitive systems.


(Sascha Egerer) #6

I’ll open a support ticket…


(Jon Mayfield) #7

Aha, that solves it.   I’ll fix that now and it’ll go out in the next update.  Thanks!  

If you’re a bit technical and want to dig a bit you can go into Library->Application Support->Zwift->assets and change the ‘Workouts’ to ‘workouts’.  To get to Library from the Finder you have to hold down the option key and then click “Go” from the menu at the top of your screen.


(Sascha Egerer) #8

Yeah thanks Jon. I’m a developer and i think thats the reason why i found out how to fix it :wink: Already did it. Works fine, thx