I can no longer see Treadmill Smart Speed or Runcline as speed source on Windows 10 or MacOS versions using Bluetooth

Since Game Update 1.16 - August 19th, 2021 - I can no longer see Treadmill Smart Speed or Runcline as speed source on Windows 10 or MacOS versions using Bluetooth

After the last update I can no longer see my smart treadmill listed as a connection. I can see it over in the bike selection but it does not work. I have reset my apple device and logged back into Zwift but to no avail. The update did not affect my bike working with Zwift


Seems to be any GEM/NFC/FTMS based connection. So I can’t connect my Woodway treadmill on any device that’s been updated. Seems we have only 3 more days until all devices are forced to update and the ability to use zwift will be gone for a while.

On the run data source screen after the app update it registers the treadmill as an option for a few milliseconds (blinks in) then disappears.


Hi I’m a ATV user and have the same problem. Wahoo Kickr and treadmill are shown in ride section. Wahoo Kickr works as it should but treadmill can’t connect as a running tracking device. On iPad (not updated yet) no problems with pairing. It is obvious a problem related to the latest update. Hope Zwift with solve this on short notice or otherwise no running via Zwift on treadmill.

I recently updated Zwift and the Zwift companion app and am now unable to connect / Pair with my Smart treadmill ‘Horizon Omega Z’

I was able to pair treadmill on home screen without issue before recent update.

I tried connecting via IPad (how I normally sync), IPhone and also laptop unsuccessfully today.


Runn is no longer found, however Zwift does find it when in ride mode, bit not run mode…ipad used and latest update yesterday…I’ve informed zwift and they will look into it ASAP… nothing can be done just now

1 Like

Very frustrating. Technogym myrun using most recent firmware won’t pair with iPad (running OS v14.7.1) following Zwift 1.16 installation.

The treadmill will pair with iPad to use technogym app (so it’s not Bluetooth or treadmill issue) and Zwift pairs with my Garmin fenix 6 watch so appears to be a specific problem with Zwift and the treadmill.

1.16 is a POS. C’mon Zwift sort it out.

1 Like

I had the same problem last night when I tried to connect Myrun treadmill to Zwift. I’ve used my treadmill for the last year without any problems until last night. Very frustrating, I like everyone else on here can see Myrun in ride mode but not in run mode. ZWIFT - PLEASE SEND US AN UPDATE ASAP. Thanks


Plus one - experience the same issue… treadmill now only listed as bike source.

Hoping for a quick turnaround on the patch as have limited time to use other devices not yet updated before the update is forced.

1 Like

Same here, everything used to work fine - not a single sensor showing in the Run sensor discovery after last update. Only can see them in the ride section.

My NPE Runn is not working with the companion app but works with the PC built-in Bluetooth. Stryd does connect with companion app and works. Sometimes I have to try a few things before Zwift recognizes it.

Same here… I‘m unable to pair Zwift over my iPhone with my „Cardiostrong TX 90 smart“ treadmill. When I try to connect I can‘t find the treadmill in Running screen but when I switch to Bike screen the treadmill can be found as power source. But I want to use the treadmill in the Run screen.

Out of 12 run I had, I only found the treadmill bluetooth twice. Before the update, everything works just fine.

I was told by a Zwift ambassador that it might help speed up the process if we all hit the vote button at the top. Hopefully Zwift can fix this soon. I spent way to much time trying to figure out what was wrong, before I realised the update had messed it up :woman_facepalming:


I have the similar issue here. I used to use Stryd through Runcline to log my incline information, but only to find Runcline source is just available as power meter for ride…
Hopefully this can be fixed sooner!

+1 following.

Ditto. Thanks for pointing out the Vote button up top.

I have the same problem. Anyone can help?

I am also having an issue with my treadmill no longer being recognized in Zwift Run. Zwift thinks my Sole F80 is a bike trainer. It picks it up in the cycling section but not the run section. Zwift, please fix. (By the way, I am attempting to pair with an iPad.)

Same issue with the sole f63 on macos, windows and Android