How to Trigger Choice of World and/or Route

Hello everyone.

I believe that I’m supposed to be offered the choice of either Watopia or one of the Guest Worlds when I start a ride. And also to get the chance of choosing a Route. How do I trigger those choices as I never see them? Is it a settings choice that I’ve not made? Or something I’m doing wrong? How is it supposed to work?

I’m on MacOS, updated yesterday, so I guess it’s the current version.

Thanks.

It’s on the screen right after the Pairing screen.

On the top of the screen you will see the World Choice and directly under that you will see the route choice

Thanks Paul. I have seen that in the past but I don’t get it now. After pairing it takes me straight into the guest world. Strange or what?

1 Like

What is the version of Zwift that you are currently on?

Well Paul, it might be 1.0.43801 'cos that’s what shows up on the ‘Login successful’ screen. Then it took me to the Pairing screen and I continued without pairing to see whether I could see a version anywhere as the About option does nothing. Then, after a warning that I’d not be able to ride without a speed sensor, up came the screen you shared with the choice of worlds. I’ve not seen that for weeks! Might the pairing process interrupt that somehow? I’ve switched from Bluetooth to ANT+ recently 'cos it seems more reliable with the Trainer.

Pairing via BLE or ANT+ should not make a difference in seeing that screen. I have been using ANT+ for years and I always see this screen.

FYI, that is the most recent version of Zwift.

OK. I’ll keep a close lookout next time I Zwift for real and see what happens.

1 Like

Here’s an update. I think the issue is caused when both ANT+ and BLE are enabled. When I’ve started up Zwift with one or the other then the choice appears and waits for you to make your choice. But when they are both active then the choice screen flashes very briefly (you have to watch really carefully to see it) before landing you in the guest world.

I call that a bug. How do I get it looked at?

Hi Nick,
I always switch off Bluetooth before I start up Zwift.
I do this so that all my devices are connected by ANT+ only.
Only when that is complete do I switch bluetooth back on.

I do that, so that I decide what hooks up which way.

Thanks; that’s what I’ll do from now on. Nick

I’m having this issue! Screen goes from welcome, to pairing sensors, and then after “lets go,” it goes straight to watopia. No world choice screen whatsoever. I have turned off the bluetooth on my computer and iphone and using just ANT+, same issue. And vice versa. How did you guys figure this out?

You are seeing the new user tutorial: https://zwiftinsider.com/video-start-riding-on-zwift/

1 Like