How do I get Zwift to start up "Full Screen" on an external monitor?

I’m running Zwift on a Windows 10 laptop with an external display connected. I’d like to run Zwift in “Full Screen” mode on the external display.

The laptop is Display 1, the external monitor is Display 2. I start Zwift by clicking on the Zwift icon in the Taskbar on Display 2. Sometimes Zwift starts on Display 2. Sometimes it starts on Display 1 - in which case I have to change the Settings from “Full Screen” to “Windowed”, quit and re-star Zwiftt, and drag the Zwift window over to Display 2.

Is there a trick to getting Zwift to always run “Full Screen” on Display 2?

Thank you!

You will need to make the secondary monitor you main monitor in windows Settings.

Or what I do is run borderless-gaming and then run Zwift in windowed mode.

2 Likes

Ok, I made Display 2 my Main Display. And Zwift does now seem to run on Display 2 in Full Screen mode. Thank you.

Next problem… Any time I click on anything on Display 1 (say, a web browser tab, or just the desktop), Zwift disappears (minimizes?). Any ideas on that one?

And that my friend is why I use borderless gaming.

All games does that, that is just how full screen gaming work, some games will even force your mouse to stay on the game window.

1 Like