Help with troubleshooting pairing issue


I use Zwift since 1 month and i use a Elite Qubo Smart B+ Trainer i purchased 3 years ago. I used the trainer 3 years ago and did not zwift until 1 month ago when i started again.

Today I started Zwift, an update was applied and then i was not able to pair devices.

In fact Zwift recieves some data, i see power and cadence boxes lit (they become blue) but the data displayed is not ok, moreover “Error” is displayed in the cadence box. After trying to start Zwift several times last time pairing seemed ok (I could read reasonable power and cadence values), anyway when i started a workout power was always at 0 cadence was 1 rpm, but from time to time a strage value (like 242370487) was displayed for a fraction of a second, than 1 rpm was displayed again.
Result is I cannot ride.

Do you have any idea of which could be the cause?

I imagine the following causes:

  1. today upgrade introduced a problem
  2. a problem with the battery

I do not have a 2032 battery with me to try the replacement, i need to purchase it, anyway i did a workout 2 days ago and the trainer was wokring fine, today it never worked so i do not think battery is a problem, i will try to replace it anyway but this sudden realiability problem makes me think to a software upgrade issue.

Could you please suggest me what i can do to further investigate the problem?


I’m sure someone else will have better information than this, but it might be a place to start. Just because the boxes are blue doesn’t necessarily mean things are paired correctly (especially after 3 years). So, you might try going through each pairing box to make sure the correct device is being picked up. Before doing so, you should also make sure that your trainer is updated with the latest firmware. Beyond that, I’m not sure I can be of any help.

Thanks for the reply.

In fact today i decided to misure the battery (2032 3V battery) voltage and it was 2.7V (less than 3V) so it means battery is gone or almost gone. I purchased a new one, installed and problem solved.

Honestly i was mislead by the fact that i managed to complete a workout 2 days ago, but yesterday i was not able to pair devices, likely the battery was at end life and yesterday it really died.

So even if not used for 3 years the battery has gone, i also stored the trainer in a cold room so battery suffered likely.

Anyway problem solved. Thanks,

1 Like