Help: No XP (or very little) awarded for successful workouts

Hello! I’m new to Zwift. Riding a StagesBike SB20 and using Zwift mostly on an iPad Pro (2018) with Zwift Companion running on a Pixel 4 XL. All software is verified up to date.

Nearly all my rides are workouts on ERG mode. But I’m getting no XP (or very little) during my workouts. I understand workout XP is awarded on some secret recipe of time and stars, but the Zwift Insider’s “XP in Workouts” article estimates you’ll get a full star if your power is within ~12% of the target. And I can’t believe I’m anywhere near that far off target, in ERG mode and at high Zone 2 (endurance) power.

Annoyingly, neither stars nor XP earned on a workout show on the activity feed. But although this seems to happen on most workouts, I can provide at least one crystal-clear example: on Nov/21, I completed a workout titled “Endurance 150W (Royal Pump Room 8)”. There is a 90-minute interval at 150W (roughly 70% of FTP) in that workout, which I completed well (IMHO) and I got exactly 167XP for it instead of ~900XP. Why?

My power was a little choppier after ~72 minutes and I stopped three times to adjust my clothing and position (still quite new at the whole cycling thing). But Training Peaks shows average power of 150W and normalized power of 151W and the graph (though the forum won’t let me post it) looks pretty good to me!

I can’t imagine these blips are so heinous as to make Zwift decide that I failed the interval. I’m really frustrated. Can someone help me figure out what’s going on? I’m losing nearly all of my XP… roughly 700-800 XP on this ride alone and probably 80% or more of what I’ve earned.

Any thoughts/advice appreciated. Thanks in advance.

hi Rodolfo,

In the companion app you need to run the Workout Headsup display. You have to keep the needle in the prescribed zone marked with whatever color the zone is. When you are on target the whole speedometer horseshoe will pulse the correct color. If it isn’t pulsing you aren’t in the zone. I use my iPad in portrait mode in the SB20 holder. I find that it forces me to focus on meeting the workout target. I run Zwift on Apple TV and pay zero attention to the commands there. I use the ATV for scenery only.

You have to learn to work with ERG not chasing it up or down. Overshooting is wrong as undershooting. I can manage 100% stars at times and I have bombed some as well. The one’s Zwift thought I bombed, I know I aced.

I have never stopped for any reason but stopping without hitting pause will surely reduce the time in zone and lead to not making the required %.

First, thank you for the detailed feedback and suggestions.

I believe I’m generating pretty consistent power already. I pedal at 98-100 rpm and try to be smooth, not chasing the numbers: my power variations are just the usual Erg mode ups/downs.

I’ve had ZC on the Map page, not the Workout. I’ll use that on my next ride to verify whether I’m stepping out of the zone… but I wouldn’t think so.

Try shortening the interval duration and creating a workout with many identical intervals of say, 3 minutes. You’ll be able to see your gold stars (and XP) being awarded more frequently. BTW, you may also find the following article to be helpful…

8 Ways to Earn More XP and Level Up Faster on Zwift
](https://zwiftinsider.com/earn-more-xp/)

Thanks, I’ll give those a try too.

Update: I broke a two-hour workout into five-minute intervals. It’s massively annoying to work gradually through 24 intervals while having to use your total elapsed time to figure out where you are in the workout, but I ended up getting 16/26 stars so I guess things are getting better.

I noticed that most of the intervals where Zwift “failed me” were ones where I adjusted something (clothing, position) and briefly got off cadence, provoking a power spike for 2-3 seconds as I got back into my rhythm. Any interval that had a power spike, even for 2 seconds, got failed. I’ll try to finesse it and learn how to smooth out the power to avoid those brief spikes, but again… massively annoying. And I really don’t see why Zwift should be so demanding about workout compliance.

I don’t intrinsically care about XP – I just want to do my workouts and get better at cycling – but because some routes and many bikes, wheels, etc depend on it, I’m kind of forced to “care” about it for a while. Ugh.

Something seems amiss… It’s my understanding that the proverbial Gold Star is awarded when you meet the power-band requirement of the workout interval for 85% of the duration. A few seconds above or below a five minute component should NOT cause this to happen. I suspect your concentration may be waning more than you realize. How does one get to Carnegie Hall? Practice, Practice, Practice. You’ll get better. Keep at it.

Something else it wrong here @Rodolfo_Paiz - I had a look at a few of your photos on Strava and you dont seem to be have smooth power at all. With a smart trainer, you should have at least graph like the one above from Wes (smooth blocks), i.e. regardless of your cadence/power, you will have a smooth block. Another example is below on a recovery ride I have set up as a custom workout. Regardless of the small changes in power - they are all smooth blocks …

Yours even shows a 20w difference!

Are you able to take a screenshot of your pairing screen?

Also note your power chart from Strava - this was from your workout with a series of 150w intervals where I would expect to see a nice smooth line…

And here’s mine from the ride above …

It’s reasonable to suspect that. :grin:

The power band is pretty broad: when I’m targeting 150W, I think it gives me 20W on either side of my target. I’m pretty sure that I’m not out of that band anywhere near 15% of the time. Is there any way to download my exact power output second by second, so I can analyze it and get true statistics?

Thanks for taking the time to look at this. It’s my understanding that many smart trainers send smoothed power (3-second or 5-second watts) to Zwift whereas the SB20 StagesBike sends the exact, instant power. That may indeed be part of the problem and I wonder if there’s a way around it. (Note: this 20W difference you see is common, as the power numbers jump around a lot by up to 15-20W every second, but it’s still within the allowable power band.)

But so far, I’m getting the impression that Zwift will fail you either for being out of the power band too much of the time, or if you have any power spike that’s high enough to touch the red line. And I think it’s that second one that is killing me. But I do need to put more work into figuring this out.

I’ll try to find a way to download my exact power data and analyze it in a spreadsheet. That would help me provide better data. And yes, I can get a screenshot of my pairing screen and will happily do so later. Out of curiosity, how does that help?

Rodolfo,

In the setting section of the Menu in Zwift you can switch between 1 second and 3 second power reporting.

@avid_dk - good call, though this is purely cosmetic and wont be the cause of not hitting power targets but you never know with Zwift these days!

@Rodolfo_Paiz - I didnt realise the stages didnt have power smoothening and is likely the cause of inconsistent graphs as well as you missing your targets! If I turn off power smoothening on in my Wahoo settings, I cant have ERG on, or at least turning ERG on turns my smoothening back on.

Re pairing screen - I was curious that both Power Source and Controllable were configured to FE-C - but I’m thinking thats not the issue.

As you pointed out earlier, you get your fails when you drop your cadence/adjust power etc - with the Kickr’s at least, unless you stop pedaling or the power target is too high, you fairly much cant fail. So I am thinking your partial fails are related to that lack of smoothening in some way but then I would have thought that if it was an unresolved Stages issue, a lot more people wouldnt be happy.

I found this post - have a look at point 2 Issues with Stagesbike 20(SB 20)

Here is a set of intervals from Zwift Academy done on my Stages SB20.

Interesting tactics you have to deploy to hit your targets David. I’m therefore guessing thats common to all youSB20 owners. We Neo/Kickr/etc owners have it easy then!

I re-read you post about Wahoo power smoothing and I see what you are saying. I am getting better and better at hitting the targets. Will I ever be able to carve vertical ascent and descent with flat tops, probably not.

Yes, thanks. I’ve had mine set to 3-second since Day 1, and it works well in free-ride mode. But the experience in ERG mode is totally different. I’ve done a lot more research, and have now found a bunch of people (GPLama and DCRainmaker being perhaps the best known) who all say that the SB20 works beautifully in many ways… but that it reports power very erratically in ERG mode, hopping up or down 25, 30… even 40 watts all the time.

Sadly, this seems to be an SB20 software issue that will hopefully get fixed with a future firmware update. Overall the bike is amazing and wonderful, so I can live with one or two things that don’t work well, especially if they can be fixed. For now, I’ll just do the best I can to get some XP during workouts.

Thanks VERY MUCH to all of you for your efforts to help and for your suggestions. At least using the short intervals, and trying REALLY hard to be steady and smooth on the pedals, I’m getting about half the possible XP and may be able to get better with more practice. Something is better than nothing!

2 Likes

Maybe also try doing a workout without erg mode? I was reading this thread because my SB20 shipped and I’m excited to get it set up, even if it isn’t perfect. But I’ve full-starred a ton of workouts on my old indoor bike (with a power meter and hand-turned resistance knob), where I absolutely overshoot at the starts of intervals. So while I’m looking forward to trying erg on the SB20, if it doesn’t work well, I expect shifting it to be way better than having to reach for a very hard-to-set-accurately knob.

Sarah,

No worries, you will love your SB20. If you have full starred WOs in the past it won’t be any different. I have 3500k on my SB20 and couldn’t be more satisfied.