Help! Keep getting dropped from server :(


I’m running version 1.0.54377 (inc France and the Maap sign-up box) on PC, so I believe that is up to date. I’m connecting through Ant+, using a Saris H3 and a Coospo HRM.
My internet connection is wired and via powerline plugs, so definitely no wireless issues.
There are no updates available to me for my Android companion app - the problem happened yesterday while I was using it, and twice today without using it at all.

I had a couple of instances of this a few weeks back… everyone else in the world vanishes, either instantly or over a few seconds, and the ride will not then download to Strava on exiting and some of my progress is lost.

After it happened the first couple of times, I had a Google and I understand that the problem is that I lose my connection to the Zwift server. However, my internet connection itself seems absolutely fine - I have no trouble connecting to anything else, and I generally ride while streaming music. Experiments with that suggest the music buffers for a couple of seconds at most, so I am pretty certain my connection does not have a problem when Zwift drops.

I had it once again a couple of weeks ago, but it’s been solid until the last 2 days.
Last night I completed the Jungle Loop and it dropped almost after immediately I had finished the loop, although it did record my route badge. I was using the companion app.
Today, I didn’t use the app as it seems from my googling that there’s a chance it might be involved in these drops. however, it still dropped from the server 5 minutes into RGV in France, and then once I’d got it rebooted and running again, I just tried the Champs Elysees… again, it dropped immediately after completing the route - I got the banner for the badge, but this time it has not recorded it to my profile.

Obviously, losing progress that has been sweated for is rather annoying; I’m getting nervous about starting the longer rides… can anyone help me with this??
Thanks in advance!

The issue could be outside of your control and reside with your ISP.

You could restart your route and/or modem.
You could also check to see if there are any updates for your router.
You could try different DNS server.

How far away are you from your router? If possible I would run a CAT6 cable instead of using Powerline.

Hi @Defblade

Shuji at Zwift HQ here. Your partial logs get uploaded to our server, and I used to confirm that there is some network disruption happening in the first few minutes. Two of your most recent log files look like this:

I invite you to locate your logs and try it for yourself.

The hard-wired connection is a good move, but as Paul suggested, network disruptions can happen over Ethernet too, and also upstream of your home or ISP. Zwift requires low latency bandwidth because it has to respond very quickly to changes is your power output. It’s not buffering 30+ seconds nor playing back a predictably linear data stream like, say, Spotify or Netlfix.

I too suggest you reboot your modem, followed by the router, and finally your laptop to reset the home network. After these three steps, I’m curious if your log reports improve?

Thanks, Shuji. I’ll have a look at all that over the weekend; maybe run several shorter sessions and see what they look like.

@Paul: also thanks for posting ideas; I do play quite a few other on-line games without this sort of issue although that is on a different PC - still on powerline connectors, but rather closer to the router as my pain cave is in the garage at the far end of the garden. Running cable out to it is not really an option, except maybe as a test… and although I’ve just had 3 in a row, I’m not sure yet that it’s going to be a sufficiently reproducible a problem to be worth the hassle…

Had enough time for a quick ride tonight, but not investigations :wink:
I reset my powerline adaptor (I think I’ll leave it switched off when i’m not using it in future anyway) and didn’t stream any music (and had an update to download, which seemed to fail the first time - stuck on 7 minutes for a while, then went to 94 minutes… I quit and restarted the PC, and Zwift fired straight up with the download complete as far as I can tell… new version number).
I then completed a lap of Champs without dropping… interestingly, despite my not being awarded the route badge yesterday (I received it tonight), the system did have a PR for me for the whole route?!

Dropped twice again today :frowning:

Both times on RGV France, one about 7 minutes in and the second about 17 minutes in (having a really nice ride with a friendly bunch).

So, first off, the fail logs from a couple of days ago:

Then the successful one from last night:

And now today’s:

I was streaming music on that one, and I noticed that there were a couple of attempts to connect to the Companion app around the fail time. I wasn’t using it as such, the phone was in the house and just sitting around, but I went and force-stopped the app anyway while I re-booted everything in the pain cave.
Then 17 minutes into the next ride (no music or anything else streaming):

These don’t mean a lot to me except that things are ok and then they’re not, so any help will be much appreciated! This is sooooo frustrating!

Can you manually change the channel on your modem to 1 or 3 rather than auto? That might help get a more stable connection.

I’ve got an all-in-one modem/router on broadband with 20Mbps line speed (good for the far end of Wales!)… I’ve had a good hunt through the settigns, but I can’t find anything that would make anything more or less stable… there is a port forwarding option, but Zwift is not in the pre-defined list, and a quick google suggests people have tried this before without any luck.

If I were to just wait and keep riding, is there any (real) chance the server connection would come back???

Just confirming its fully wired connection? Regardless, you have network issues somewhere you now just need to find the source. And yes, sometimes Zwift does recover but I would suggest that its only over shorter duration failures.

On your zwift pc and when doing a ride, you should run a continuous ping to an ip device in your house (preferably not your router/modem but maybe another pc?). At the same time, run a continuous ping out to say When you get you next failure/zwift log, you will be able to line up timestamps. If your ping to Microsoft continues nicely during zwift problem, and the internal ping fails, then issue is likely local. If the pings both fail, its on the ISP side of your modem.

Let me/us know if you need specific instructions (unsure of your knowledge level).

Yes, it’s fully wired - so long as you count powerline adaptors as “wired”. Certainly no wifi involved.

I’m nearly 50, so grew up with MSDOS… perfectly happy with command line stuff :wink:
My knowledge level has now improved from 10 minutes of Googling and testing… I’ll try these tests later, thank you :slight_smile:

1 Like

I uninstalled/reinstalled Zwift yesterday.
It took half an hour of fiddling around to get it to run today; it wouldn’t fire up at all (“server took too long to respond”) until I’d managed to turn auto-start and background updates off, then restarted a few times and yadda yadda yadda; not sure what worked in the end. Turns out there’s a LAN manager hanging about on the PC, so I’ve set that to “game mode” and given both zwift and zwiftlauncher “high priority” in the meantime.

Eventually, went for a ride - RGV again. And no problems, of course. Even increased my FTP by 2 - my first increase! :smiley:

I pinged Microsoft, my other PC and the Zwift server that came up in the earlier “can not connect messages”, zero packets lost to any of them, 4ms average for my own PC, and the Zwift average time was slightly better than Microsoft’s - both about 170ms.

Guess I’ll just have to keep firing up 3 cmd prompts and logging each time until it drops again.

1 Like