Hammer 3 - Resistance problems suddenly developed in December since latest release

Note: This issue may not be related to the most recent update of Zwift. Just suspicious.

This behavior has been observed on two different Hammer 3 trainers of the same age. My wife and I both have Hammer 3’s that have been working flawlessly (or a least consistently) on Zwift for the past 6 weeks. We both use Surface Pro 7’s with Windows 10.

Context: Typically, I execute workouts with ERG mode off. In workouts this week, we have observed the following behavior:

  1. We are executing a high intensity interval, but we have to execute it in a very high gear and we have lower than usual resistance. This is weird to start and we were riding at 100+ cadences to hit our target. During my threshold interval I was out of gears and hammering at 120 cadence. My wife was also in the big chain ring at 105 cadence.

  2. At the switch to a recovery interval, we suddenly feel a change in behavior and resistance piles on. It feels like we have moved to ERG mode and the trainer is pushing back. I have seen a pop up on the screen that says that the ERG is activated. However, it has been a devil to get it to turn off. Note: Neither of us turned on ERG mode and the companion app does not indicate you are in ERG mode.

  3. Moreover, the ERG just feels like it is trying to kill us. You simply cant get your cadence and power up to overcome the ERG and get it to back off. Wattage that is very achievable becomes unachievable.

  4. The only way out seems to be pause the workout or sit by the side of the road hoping Zwift will bail out. Switching ERG mode on & off in the Zwift app does not seem to be a reliable fix.

  5. It happened to me earlier in the week in a keep together meet up during a threshold interval workout and to my wife during a longer solo ride today. On a group meetup, this is basically the end of it for you. You get dropped and you are done.

  • On trainer 1 (mine). I immediately updated the trainer firmware & recalibrated the trainer. I also did the same on trainer 2 (hers) at the same time. Mine was reliable yesterday on a solo ride, but hers today was a complete train wreck. As a result, I don’t think it is a firmware issue.

  • In addition, it has happened on two different trainers with two different riders with different power profiles. 2.0 w/kg vs. 3.4 w/kg. I suspect it is not the trainers either.

  • I was connected using Ant+ and she was connected using BT. So not sure connectivity can be blamed unless dropouts may cause an issue. The connectivity is sometime imperfect esp. Cadence readings.

Conclusion:

So the only thing I can figure is Zwift has developed a glitch. Has anyone seen this before?

My wife was in the middle of a long ride today and let’s say it was frustrating and made the workout unachievable. After some consternation, we got her back up and running but let’s say confidence is shaken and marital bliss is shaken :slight_smile: for today.

I have a long group ride to lead tomorrow, where everyone is in keep together meetup mode, and executing a workout together. You can imagine this will be poor experience for all if the group leader and coach blows up during the workout and gets a virtual mechanical.

Thanks much for you help & i have my finger crossed for tomorrow.

Peter

Peter, I don’t know how long you have owned your H3s but many went through a very bad time this late spring with similar problems. For some using Ant+ solved the problem. You need to unplug the trainers after every use. Not sure how you force quit an application on a Surface pro. I guess a reboot would be the surest way to make sure nothing is left from a previous ride.

Another user found where the antenna was located on the H3 and placed the receiving equipment as close as possible to it. They said it solved their problem.

You may also be having complications from two of the same trainers on Zwift. I would make sure that you are not having issues with crossed connections. Make sure that Zwift isn’t connecting to the wrong trainer or switching trainers during rides. The surest way is to have the other trainer unplugged and the other Surface pro rebooted.

David,

Very helpful.

The trainers are turned off each night so I think that is fine.

The computer in use was in a slightly different position today. This was true of my debacle the other day as well. Not significantly but if the antenna is at fault I could see this as the differentiator. Will be sure to set up tomorrow does not deviate from what has been working for weeks.

Will also be sure the surface Pro’s have been rebooted before we start.

Fingers crossed for tomorrow’s ride.

P

Peter

Im having this issue as well. bought ant+ didnt solve it. tried it on apple tv + bluetooth. on macbook :slight_smile:
Still every no and then the trainer seems to go to his max power out of nothing.
Also it sometimes is running like e.g. 200 watts and few minutes later it feels like 4-500 :wink: Also have a power meter on the bike (not connected to that device but to my polar watch).
I know this can influence the signal but it started before i had a powermeter on my bike :wink:
I think it started somewhere around novembre for me.

So i actually think there is a actual software issue in place :slight_smile:
Ill try to do my training on another app then zwift to see if this solves the issue :smiley:
My devices:
Macbook pro 2019

  • tried both ant+ and bluetooth (in multiple rooms)
  • apple tv
    Elite direto XR