Greatest London Flat distance wrong

Having raised this directly with Zwift support and having had what I suspect was a form response, I thought I’d mention it here.

I ride the Greatest London Flat course regularly. It is listed with a distance of 15 miles, but it is actually closer to 15.75 miles in length. The distance remaining display counts down based on the stated 15 miles, but when you get to the last 0.2 miles and the display switches over to feet remaining, it shows around 5000 feet - nearly a mile - rather than the more usual 1000 or so feet. This makes judging the amount of effort to put in towards the end of the ride awkward.

I’ve not noticed similar errors on any other circuits; just on Greatest London Flat.

Hi Simon, thanks for reaching out!

There is a lead in of .3 miles before the route starts. This could be the cause of the length difference you have noticed.

Feel free to reach out with any questions or concerns; we would be happy to assist in any way we can!

HI Alex,

Thank you for your reply.

But it isn’t the lead-in - the extra half mile or so is added at the end. The distance remaining is shown counting down as expected, but when it reaches 0.2 miles (which is 1056 ft), the display suddenly changes to show ~5000 ft, which is nearly a mile. On every other route I have ridden, when the distance to go reaches 0.2 miles, it drops to ~1000 ft. For some reason, on this route alone, at the point at which the distance changes from being displayed in miles to being displayed in feet, around 0.8 of a mile is added for no apparent reason.

Can confirm that I experienced this weird switch in final countdown distance on that same route a few months ago, in a solo free ride, running Zwift in metric.
At the time I did nothing about it as I recalled it having been mentioned here a while back as yet another longstanding bug.

Here you go. Took a minute of googling.
See middle paragraph of OP: Route distance to go bug and route selection bug

1 Like

Thanks for reaching back out Simon, and for confirming that for me! Thank you Roule for providing another similar situation!
I understand your concern and have reached out about this on your behalf, if I learn anything more I will reach out with more information here!

Hi @Simon_Long1

Just to chime in here real quick, I’d previously reached out to the team regarding this issue and we got an official bug report in a few weeks ago as evidenced here.

The other one was for the Volcano Circuit route, so evidently this is happening on multiple routes. We’ve flagged this up so the developers are aware of all the details as they work towards a fix. Thanks!

Hey all, this bug has been fixed in Zwift game version 1.26 which just released. Please update at your earliest convenience and let us know that the distance is showing correctly. Thanks for your patience.