Graphics messed up

Hi. Yesterday and today when using Zwift on my laptop the graphics are messed up. If near to other riders they are projecting a contrail of different colours and I cannot see the trail ahead. Sometimes the tarmac roads become grass and the map in the top right of the screen is black apart from rider dots. I am running Windows 11. I have shut down everything and restarted, which worked yesterday, but not today. I don’t have an issue on my Android phone. Can you help? Is it related to the recent updates?

More likely to be a Windows update to be honest. Check the update log to see if the drivers were updated recently.

What GPU are you using?

Hello Stuart.

The GPU is AMD Graphics.

The odd thing is that it only appears to affect Pace Partner rides in Makuri Islands or solo rides in Makuri. Wattopia and New York today are working as they should.

If I test different routes then come out without saving then the menu page shows the heading but the pictures are just vertical lines. If I then go into a different route it takes ages to load before kicking me out of Zwift.

Need more than AMD to help diagnose but there are known issues with Windows 11 & Intel processors.

Makuri is renowned for being tough on GPU’s which could explain why it’s isolated to that world.

Run your fit file through Zwiftalizer which will offer some clues and check your system error logs.

The full spec of your setup would help us greatly.

1 Like


The GPU is AMD Radeon.

Zwift was working fine up the 27 April, then I took a break until two days ago.

I have signed up to Zwifalizer. But don’t know how get the fit file you mentioned or how to access the error logs.

I have added a couple of pictures.

Can you share screenshots from dxdiag.exe that show your hardware and driver info?

When the app closes unexpectedly, there will probably be something logged in Event Viewer that might provide clues.

Ha, that’s not narrowing it down. Do as Paul has suggested or bring up your system details from the control panel and it’ll have the exact details there. Suspect it’s a Windows / Intel 11th or 12th generation clash.

1 Like

see: Locating Log Files

Hi Stuart

I have attached a screen print of the dxdiag.exe and the first ‘Log File’

I hope that helps, and I appreciate the patience as I am not a techy

Best regards


(Attachment Event Log 07.56am.docx is missing)

No probs, still doesn’t give us the exact detail for some reason. Zwiftalizer is the way forward.

Run the file through that as screenshot the results page which will point us somewhere.

Hi Stuart

Resending the Event Log from my ride this morning.

Hope this helps


It is a lot more helpful if you put the Log.txt file in and share the link to the analysis

the link look like this. we only need the bold section.

Hello Gerrie

I have attached the link as requested

Best regards


Hello Stuart.

This morning I rode 30 miles with Pace Bot Bernie in Wattopia then tried Bernie in Makuri.

Once again Makuri is unrideable and the same as yesterday.

I did change the resolution from 1080 to 720 but it made no difference

I hope you can help as I love Makur.

Best regards


Hi Gerrie

Did it help when you saw the Log I sent to you?

Today I rode 30 miles with Pace Bot Bernie in Wattopia and all was as it should be.

Before I finished I then clicked on the link to join Bernie in Makuri and the graphic issues was still there.

This afternoon I did a full uninstall as per the Zwift instruction (saving the CP file) as a backup, and then re-installed it.

I was able to view the Bernie pace ride (I am not connected to the kickr), there is no picture breakup but as you can see, there is grass instead of a tarmac road.

I have also noticed from playing around on the laptop is that from going in and out of Makuri checking the screen, it sometimes freezes the screen and I have to control, alt, delete to come out of Zwift.

I hope that this additional information helps to resolve my issue.



Hi, as an update to this and the latest game update i can confirm that i cannot ride Makuri in anything above 720p.

Did you have any further ideas as i had never had this problem prior to the 1.39 update.