Graphics Card not Recognized?

My PC build:
-RX590 8GB GPU
-16gb RAM
-B450 MoBo
-Ryzen 5 2600X CPU
-SSD storage

I believe the GPU is not properly recognized due to the low quality of graphics that are being displayed.
My highest option for resolution is 1080p, but I always have Minecraft looking shadows around my rider and everything else in game is very low quality.

What is the solution for this?

Do you have the HDMI cable plugged into the RX 590 or the the HDMI port on the motherboard? Is the driver updated? Does your PC recognize the RX 590 being installed? Did you plug in additional power the the RX 590?

-HDMI 2.0 plugged into the GPU
-Driver is up to date
-PC defo recognizes GPU as I’ve been doing 2k gaming as well, on AA and AAA games with Mostly High and Ultra settings.
-GPU is plugged into PSU

Weird, I am using a RX 580 and I have no issues with increasing the level of graphics within Zwift.

You could look at this link: https://kb.zwiftriders.com/tuning-maximum-gpu-performance

Or just delete your prefix file and see if that resolves the issue.

What does deleting the Prefix file do and what is a prefix file?
I’m new to the PC world.

It will just remove any custom Zwift settings, no data or records will be lost.

prefs.xml ?

2 Likes

Good to know, I’ll try this out.

Yep, stupid autocorrect on my iPad.

Nothing has worked and I tried to reinstall Zwift and still I have the same problem.
I’m pretty sure the GPU isn’t recognized properly as I’ve been running AMD Wattman while in Zwift to see how much load the GPU is under and nothing is ever 100%. The GPU usage is fluctuating all over the place, and the avg usage is around 50%. Temp peak is like 60+C usually while running Zwift. The GPU can reach 80+C without throttling and avg 70+C when playing more demanding games on High or Ultra settings in 2k.

Mine runs consistently at about 69 degree C all day everyday when not using Zwift (using the card for crypto mining with it overclocked and set to compute, not graphics) when using Zwift I stop mining, leave it on compute and still get ultra graphics, but at a lower temp. The graphics do improve when I do switch it to graphics from compute.

You could try over clocking it a little using MSI Afterburner, but you shouldn’t need to to get ultra graphics.

Another thing you can do is when you uninstall Zwift make sure you delete the \documents\zwift folder. If you have created custom workouts you might want to save them somewhere else and if you want to keep your best wattage records you might want to also backup the CP folder. After the reinstall Zwift and see if it is better.

I deleted everything. Then reinstalled.
I don’t need to OC it at all really, it’s already an OC’d 580 from my understanding. It has a core clock of 1580, you can maybe get it stable at 1600 with the memory at 2100 or sometimes higher. I know people have said they use GTX 1060’s or RX580 like you and get Ultra Graphics. The RX590 is defo a better card all around, especially if you’re able to get a steady under volt. So, it seems after all of this I still am at the same conclusion that Zwift doesn’t properly recognize the RX590.
I appreciate the support. I sent another email to the Zwift Team, maybe I’ll get some news in the near future.
Until then, Imma Zwift it up!