GPU load too high - causing crashes - since last update


For some reason Zwift always forces a serious high clockspeed on my GPU (1890Mhz om my RTX 2080Ti) when the road is visible. With birds eye view etc, the clock lowers significantly, but for the rest it’s a relatively stable extremely high clock speed.

That caused no issues in the past, probably because Zwift was limited to 60FPS. It seems however that the framerate is unlocked since last update, which makes it run at the Hz of your monitor.

Even in the main menu, it runs at even higher GPU clocks.

Today this caused me to crash in a ZRL race and when coming back to stream it kept crashing every few minutes.

It does not make sense that Zwift keeps running my card at full boost, even in the menu. Burn in tests or games with RTX don’t even stress my card this much. Screenshot is from a few seconds into the menu screen. In game temperatures keep rising to probably over 80 degrees, but clock never lowers.

A couple of things to unravel here, but vsync behaviour hasn’t changed and your GPU is barely even trying in that screenshot. It still shouldn’t crash unless your card (or other component, like the PSU) is unstable in some way. The main menu has always caused a GPU to go crackers if allowed though. What monitor do you have?

I have a 100Hz monitor, but in the past Zwift used to run at 60FPS. Here’s a screenshot from about a month ago where I accidently had the overlay on as well. My GPU also ran at a 1890 clock speed in-game, but FPS was locked to 60FPS.

You’re almost certainly CPU bound in Neokyo, what do you have? You can set a frame rate cap in the Nvidia control panel if you wish, but otherwise Zwift will try to hit 100fps with the default settings. Nothing has changed with the game, have you done a clean install of the Nvidia driver and removed previous settings?

Anyway about the GPU:

  1. Those boost clocks aren’t unusual for a 2080 Ti. Zwift typically relies on brute force, so your GPU is boosting as high as it can.
  2. It’s literally not a problem, the card controls its own clocks based on FPS target/thermals/power/voltage. It shouldn’t crash if you’re not overclocking it and your PSU is capable of sustaining such a powerful GPU.
  3. Your temp limit is 84deg in that Afterburner screenshot, so it won’t throttle at all unless it hits that limit.
  4. Birds eye view is much easier to render, so the load reduces. This will cause the clocks to reduce if possible.
  5. Since the turn of 2022, everywhere except the home screen(s) is even more CPU limited.

But like you said, my GPU is barely even trying, however, the clock speed is just way too high. And it sticks to that speed. It does not make sense for a GPU to keep running at close to max boost when it’s not needed.

Welcome to Zwift. :rofl:

Need to sort your dropouts btw. :wink:

That is actually a good point. I should lower that by 2 degrees and the problem should probably be gone.

It is however odd that in games, benchmarks and burn-in tests I never encounter problems with my GPU, but also never encounter the behavior where the clock speed stays that high.

Lol,. those dropouts were just undisciplined pauzes during the boring cool-down part of the workout :slight_smile:

1 Like

Zwift is more effective at finding and exposing component instability than literally any dedicated stress testing tool I’ve tried. CPU, RAM, GPU, PSU, you name it. You can’t compare it to anything else so there’s no point, honestly.


It’s concerning that your system is crashing without any overclocks on though, that’s not a good sign. Should be solid. Anyway back to the frame rates; with everything at default in the Nvidia control panel, Zwift uses vsync which shouldn’t be disabled unless you really like screen tearing. For your monitor, vsync on means Zwift will run at 100fps max unless otherwise limited by something else - with a 2080 Ti this will very rarely* be a GPU limit so unless you cap the frame rate below 100fps manually, virtually anything you see below 100fps is being caused a CPU bottleneck. All worlds are unexpectedly CPU bound at present, though Makuri (and Neokyo in particular) has always been terrible in this respect.

*2080 Ti won’t come close to holding 100fps in a sudden big dust cloud, no chance. My 3060 Ti drops to ~30fps.

Clock speeds reduce as workload increases, this is the same for a CPU and GPU.
Conversely, clock speeds can increase to above quoted maximums under single-threaded or low loads. Some very old games will produce the same result.

It’s possible your card needs a bit more voltage for this scenario as most are tuned to within an inch of their life for modern high-load games.

You can use MSI afterburner or other tools to reduce the maximum clock speed or increase voltage.

Alternatively, apply a 60fps cap in Nvidia/rivatuner/other app.
Zwifts third-person view rubber bands above 60fps anyway.

1 Like

Nah it doesn’t. :wink: That annoying zooming effect happens at/through 60fps - which happens a lot without a very strong CPU (and much more since the CPU load problems I’ve complained about elsewhere). If you’re far enough below or above 60fps, it doesn’t happen. Capping at 61fps helps on a fixed 60Hz display, like a TV. Cap at 59fps if you have an adaptive sync monitor to avoid the rubber banding altogether.

Well technically it does as you can’t really stay above 60fps at all times in this triple AAA title :slight_smile:

Mine does easily, aside from tight group rides on Neokyo where the absolute lows are around 50fps. Assuming you still have the 3900X/3080 rig, Zen 2 isn’t fast enough to hold 60fps in Zwift when it’s packed.

Thank you and others for thinking along!

I think I may have found the culprit, which may not even be Zwift related. There was one thing different yesterday compared to normally.

I had left the noise reduction from nVidia Broadcast turned on thanks to working from home and leaving the window open (so causing lots of background noise) to cool my living room down before the race. Normally it is always turned off.

I think the combination of that, along with the noise suppression from Discord and the filter from OBS may have had something to do with the crashes. Since autostart was turned on for nVidia Broadcast and it keeps the last settings, I did not notice it was turned on.

I do not intend to voluntarily crash my system, but a test I did with everything turned on, even a 100Mhz base clock overclock for GPU, with Discord on and OBS recording, caused no crash.

So I think I may have looked in the wrong direction (clock speed, temperatures etc), while it may just be a software glitch from multiple GPU-bound noise reduction tools conflicting with eachother.

Fingers crossed for next race!