Zwift exiting without warning on Windows 11

Summary

Since updating Windows last night (KB5006363 & KB5007215) Zwift now exits mid-ride after a seemingly random period of time.

Details

I logged in this morning and started a ride with Coco; after about 5 minutes Zwift just exited.

I logged in a second time and rejoined Coco - with the same thing happening after ~7 minutes.

I rebooted my computer and then tried a third time. I spent ~30 minutes riding around London outside of a group ride, before the game crashed again.

I’ve checked the event log, there are no exceptions being logged - nor is there anything of interest in the various log files inside the Zwift folder.

Try checking the Reliability History. Should at least show that the application closed unexpectedly.

But you’ll need to outline your system specs to get some more meaningful help. :slight_smile:

I’m betting it’s the 10th/11th gen iGPU issue again.

That’s a new tool to me! There’s nothing related to Zwift in there at all - the only application failure it shows is that apparently The ASUS Motherboard Fan Control Service doesn’t exit gracefully upon reboot.

I’ve dumped my system info but that’s a 800KB file, the summary info is here:

[System Summary]

Item	Value	
OS Name	Microsoft Windows 11 Home	
Version	10.0.22000 Build 22000	
Other OS Description 	Not Available	
OS Manufacturer	Microsoft Corporation	
System Name	WINDOWS-DPELTLT	
System Manufacturer	ASUS	
System Model	System Product Name	
System Type	x64-based PC	
System SKU	SKU	
Processor	Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)	
BIOS Version/Date	American Megatrends Inc. 1003, 30/11/2020	
SMBIOS Version	3.2	
Embedded Controller Version	255.255	
BIOS Mode	UEFI	
BaseBoard Manufacturer	ASUSTeK COMPUTER INC.	
BaseBoard Product	ROG STRIX Z490-F GAMING	
BaseBoard Version	Rev 1.xx	
Platform Role	Desktop	
Secure Boot State	Off	
PCR7 Configuration	Elevation Required to View	
Windows Directory	C:\WINDOWS	
System Directory	C:\WINDOWS\system32	
Boot Device	\Device\HarddiskVolume3	
Locale	United States	
Hardware Abstraction Layer	Version = "10.0.22000.1"	
User Name	WINDOWS-DPELTLT\richa	
Time Zone	GMT Standard Time	
Installed Physical Memory (RAM)	32.0 GB	
Total Physical Memory	31.9 GB	
Available Physical Memory	22.6 GB	
Total Virtual Memory	36.7 GB	
Available Virtual Memory	23.9 GB	
Page File Space	4.75 GB	
Page File	C:\pagefile.sys	
Kernel DMA Protection	Off	
Virtualization-based security	Running	
Virtualization-based security Required Security Properties		
Virtualization-based security Available Security Properties	Base Virtualization Support, UEFI Code Readonly, SMM Security Mitigations 1.0, Mode Based Execution Control, APIC Virtualization	
Virtualization-based security Services Configured		
Virtualization-based security Services Running		
Device Encryption Support	Elevation Required to View	
A hypervisor has been detected. Features required for Hyper-V will not be displayed.

What GPU are you running?

Tis an EVGA RTX3080, I’ve had a look for GPU issues with Zwift on the forums here and haven’t seen anything?

Thanks!

Got the 3080 overclocked (or undervolted) at all? Zwift has a lovely habit of disappearing without trace if something’s not quite right, and it can happen when the overclock is unstable or the GPU is faulty… let’s not go there. Anyway if yes, consider backing them off.

Likewise, do you have your CPU and/or RAM overclocked? Instability with those would usually cause a BSOD in fairness, but worth checking. It doesn’t really matter if they’re stable in every other game and stress testing software btw, Zwift can and will go beyond anything else. :rofl:

Next thing to look at is whether the Nvidia driver is okay. Try reinstalling or updating it, and reset it to default (at least for zwiftapp.exe if not globally). If it’s still crashing after all that, turn vsync off and let me know if your avatar is flickering like mad.

I’ll do some reinstallations etc tomorrow morning.

The system is OC’d as you’d expect with a rig like this one - but its been rock solid stable for the 10 months I’ve had it - which includes almost daily Zwift sessions.

No vsync here as it’s a gsync screen.

Should still have vsync enabled with gsync, it helps with frame pacing. :wink: If you play other games and are concerned about vsync input lag, cap the frame rate 3-5fps below the refresh rate of the display, so you’re in the gsync range all the time. But for Zwift alone, vsync on is optimal. Search Facebook for ZPCMR if you want more of this nerdy crap.

Anyway the same principle applies, if you’re getting flickering at high frame rates (100fps+) then there’s a separate issue you need to work around. You’ve not mentioned it so I assume it’s not a problem for you, I just wondered if it could be a factor.

Reinstalled Zwift this morning, I was able to complete a 2+ hour ride without issue so that looks to have done the trick.

1 Like