getting zwift onto your TV


(Russell Marks Rev 3 Tri Team) #1

i’m having trouble getting zwift onto my TV. trying to log on through my TV browser and it says 400-bad request. how do i get zwift on the big screen?


(S Schofield) #2

Hdmi lead out of a PC is by far the simplest solution.


(Russell Marks Rev 3 Tri Team) #3

ahh ok. so you can’t just log onto zwift from your tv browser and get the graphics to show up there huh?


(S Schofield) #4

Never tried that. But I would think it is very ambitious, as you are gonna need the TV to have the computing power to run the programme. If I have understood you correctly.


(Kyle Polansky) #5

Zwift doesn’t run through a browser. You must download it and install it. This would require your TV to run windows and support ANT+ (I don’t know any TVs that do). As Simon said, just connect a video cable from your computer to your TV. HDMI will be the easiest, but VGA will probably work too.


(Tom Lehman TTR) #6

Like Simon stated: HDMI cable is how I do it.


(Kyle Polansky) #7

Russell, the Zwift web interface only allows you to change your account settings like weight as well as download your ride files and such. You can’t actually play the game through a web browser.

While I think it would be cool if that is possible, it would be pretty tough to connect ANT+ through a browser, and even harder for a TV to be powerful enough to process the graphics required.


(Kevin Bernstein) #8

Chromecast screen mirroring works ok, if you are fine with about a 2-3 second delay. However, as I found the delay unacceptable, I moved back to HDMI.

However, with stronger wifi/reduction in latency I could see Chromecast being a very viable option in the future.


(Justin Meikle) #9

I am new to Zwift having just got started on it this weekend.

Have it all running perfectly on my lap top and tonight I thought I would try plugging the lap top into my TV to give that a try. I used a HDMI cable and when I plugged that in with just my desk top showing on the lap top it displayed on my TV perfectly. As soon as I started Zwift all I got was a black screen on both my lap top and my TV. Unplugged the HDMI cable and the lap top screen came back on. Shut Zwift down, plugged HDMI cable in again and the lap top display appeared on my TV. Started Zwift again  - black screen!

Can someone please help me with this? It clearly isn’t a display issue or TV lap top compatibility issue as they work perfectly together except for when I start Zwift.

Thank you!


(Jon Ayers 60+ Team ODZ) #10

I am having similar trouble to Justin.  Zwift works fine on my computer.  But when I plug my TV into the computer with an HDMI plug, I lose all the other riders (I ride alone).

 


(Rich Jackson (LFCC)) #11

I’m having similar problem. 

Run zwift on my laptop. Plug TV into hdmi. Can get laptop screen to working TV but zwift won’t show? Have zwift showing on laptop screen and background on TV screen?? 

 

Any help? 


(Jon Ayers 60+ Team ODZ) #12

I just figured the HDMI overloaded my laptops graphics card. If it want to use the larger screen, I figure I need to upgrade to a gaming pc.  Only my speculation


(Gerrie Delport) #13

This seem like a Windows issue not a Zwift problem. but the good news is there is a lot of settings you can try. Does you tv show the same “picture” desktop as the Laptop (mirror image). Try running Zwift in windowed mode see if that work.

 

You have to set your resolution to match what your TV supports.

To check what res. your TV supports; Minimize all you windows, right click on your desktop and select Graphics Properties…

Select the information link and click on the Digital Television tab.

Under supported models it lists the resolution your TV supports.

Go to Display Settings and set the resolution on your PC to match what your TV supports and apply.