Garmin speed sensor stopped pairing all of a sudden


(Stewart Cheetham) #1

I’ve used zwift using MacBook Pro, ant+ receiver and extension cable. These are connected to garmin speed sensor, cadence sensor and HRM. This has worked fine for 2 months however now the speed sensor will not pair but the cadence and hrm are fine. I’ve changed the battery in the speed sensor and it still connects fine to my edge1000


(Stuart Middlecoate) #2

Try removing the extension cable, although you’ll probably need it to maintain signal long term it may be that the extension is the issue.  I had the same, New cable and it worked fine.


(Stewart Cheetham) #3

Thanks for the response Stuart. I tried that and had exactly them same problem. It seems like the speed sensor has gone faulty but it pairs fine with my garmin


(Stuart Middlecoate) #4

I had loads of issues with the Garmin sensors, especially the gsc10, the one that fits on the chainstay. They give the impression they’re working but actually aren’t. I had one that recorded a 3rd of the distance I was actually traveling, another that would give false cadence readings…actually bought a cheap Chinese one from Aliexpress for a tenner. Works great


(Fred Texxer) #5

There’s another topic below with sensors no longer working after the latest Zwift update, but I have a MacBook and Wahoo sensors that have worked fine with Zwift since its inception and my HRM stopped working after the latest update. Zwift can’t find it. The issue does not seem to be isolated to Mac’s or a specific brand of sensors though. One person was having an issue with their Wahoo smart trainer. My sensors still work fine with all my other apps. Hopefully Zwift comes out with a fix.