Garmin resistance control

I follow a training plan created and stored in Garmin Connect and all workouts are downloaded to my Germin Fenix 6S Pro watch. The Fenix connects to my Tacx Neo Smart 2T trainier via ANT+ and is able to control the its resistance automatically following the workout pattern if Zwift is not active.

If I am right, it should be possible to disable the resistance control of Zwift by unpairing my (controllable) trainer in the “Paired Devices” settings menu.

Unfortunately, it does not work as expected. As soon as Zwift starts, it takes control and changes the resistance (in Zwift I select “Free Ride”).

Zwift runs on a PC using an USB Bluetooth dongle to connect to the trainer.

Thank you for your help.

With my Kickr Snap, I’ve had success disabling Zwift resistance by unpairing my controllable trainer, then using the Wahoo app to set my desired wattage (so I can follow a Peleton powerzone workout).

I’ve noticed that Zwift (or something) occasionally seems to take over, so I need to re-enter my desired wattage on the app. This seems to happen just a few times each ride.

I haven’t tried controlling the trainer with my Garmin watch while Zwifting. If I get a chance today, I’ll give it a try and report back.

After re-reading your post, I have a quick question – when you said you select “Free Ride,” did you mean that’s what you selected on your watch under “Trainer Options?” If so, then I think you’re getting whatever Zwift defaults to when paired with a trainer that isn’t controllable. That’s different from using a workout on your watch to control Zwift. I think you’d want to hit “Follow workout,” then select your workout.

Just as info, I was able to control my Kickr Snap wattage while in Zwift by setting the wattage on my Garmin 945 (with the controllable trainer “unpaired”). I didn’t ride far, I didn’t try a pre-programmed workout, and I couldn’t figure out how to adjust the wattage without starting a new workout (I’m not sure it is supposed to be possible, but didn’t investigate carefully.) However, I tried it a few times at different power levels, and it seemed to work.

Thank you Michael for your quick response and support.

On my watch I select (as you mentioned) “Follow workout” and in Zwift I choose “45min Riders Choice” under workouts. Zwift displays “free ride” in this mode. Sorry for mixing up the expressions.

I would try using a regular (non-workout) ride in Zwift – that’s what I was doing when I was using the Wahoo app to control resistance, and that’s how I tested my Garmin watch.

That did the trick. However, I had to start the workout on the watch prior starting Zwift.

If Zwift is started first (controllable trainer “unpaired”) neither Zwift nor my Garmin watch takes control of the resistance and the gradient is simply set to 0 and does not change during the whole tour.

Personally, I think there is some room for improvement.

Thank you, Michael.