Game Update v1.48 [September 2023]

I can’t say if this is a bug (could be!) but when there is a possibility of wireless interference the scope of what may have changed includes everything else in the environment, not just the equipment you’re trying to use. Plus the operating system is generally not static. It’s rarely possible to confidently say that nothing changed.

1 Like

Have you tried running a Bluetooth dongle on an extention lead ?
My Bluetooth dongle is with 0.5m (18in in freedom units) from my 4yr old Kickr Core on a 4m usb lead (12ft).

I’ve always found that Bluetooth reacts quicker then ANT+ too, might help your racing performance :slight_smile:

It’s just so much that I’m out of control of on the software side of things; but it just seems odd I don’t seem to be the only person with a kickrbike recently experiencing this issue.

I’ve tried bluetooth before once or twice, it’s only ever given me bigger issues.
Also, turns out (and I cannot produce enough hate for this). My mini desktop with an ASRock board with bluetooth built in; not only can it not see the kickrbike; turns out… thanks to Windows not being able to handle two unique bluetooth dongles/antenna systems… I literally can’t even use bluetooth on this other computer of mine; because I can’t disable the bluetooth in the bios.
Drives me insane.
So for any of you other common-ers on here ever runs into someone having issues with bluetooth issues specifically on a Windows machine; definitely try to remember to ask them if their computer came with bluetooth; because for some stupid reason, not all motherboards can disable bluetooth… and there’s nothing quite like putting bluetooth on a motherboard just for it to sit inside a faraday cage of a computer case :person_facepalming:

I’ve just never had issues with ANT+ until August… just find it weird.

If it’s not that widespread then I guess I get to go back to fiddling with things; just kind of difficult to test as it only happens on rides that end up being closer to 2 or more hours

you should be able to disable one of them in device manager

1 Like

You know what I’m going to say now right?
“I’ve done that before it never works, it always reenabled itself”
(and I’m not kidding that’s literally why I gave up on it after 5 months and easily 20+ attempts)
Literally it has driven me insane to the point of giving up; which I did.

Now of course someone else says and waits for my response and … this time it worked?

Just in time for me to have to leave for work and not even get to try it out, dang you Chris!

runs off shaking fist yelling “I hate you Murphy and your stupid law!”

Couldn’t tell you why I was just able to do it this time… literally no idea.
But I guess I’ve got more fiddling to toy with tonight.


I did it on purpose!


1 Like

I think you’ll find a well placed screw driver, maybe “tapped” with a hammer too, will sort out the built-in bluetooth…

Since 1.48, I’m really struggling with the Bluetooth connection. My trainer is connected by ant+ and thankfully seems stable. Zwift Play is somewhat more reliable than previously, but my HRM is all over the place dropping and reconnecting (or not) and that has never been an issue. I know it’s not recommended, but I’ve always broadcast my HR from a galaxy watch using the hr2vp watch app. It’s been pretty flawless for several years, and suddenly I can’t get a reliable connection. I’m using a W10 pc and I’ve tried direct, usb dongle, and companion app. All very similar (ZCA worst). I’ve done endless rebooting and reinstalling as well to see if that makes a difference.
Just can’t figure out what’s changed…

Okay so… now that bluetooth finally seems to be working ( don’t judge me Chris!)

The only way steering seems to work, this is on a Kickrbike, is if I reset my sensors at the start of every session.

Otherwise, it shows it, and it says steering is “on” on the screen, but nothing will work, until I remove the kickrbike’s sensors in the sensor select screen, and re-enable it. (not just steering mind you; all of the sensors have to be removed, and reset)

1 Like

It is more pity than judgement.

1 Like

UPDATE: September 25

Phased rollout of v 1.48.2 to iOS / tvOS devices is complete. If you’ve set your device not to automatically update, please manually update in the Apple App Store.

1 Like

On 1.48.2 / latest atv os and saw consistent connection failures to my stages sb20

The power and cadence appeared to pair, but no readings were provided and the bike no longer appeared under “controllable”.

Uninstalled the app, reinstalled it and there was a new system prompt to allow the app to use Bluetooth connections. Saying yes to that and everything is good again


HI @K_Vandesteeg welcome to Zwift forums.

Your symptom can also happen when Apple releases a new version of tvOS. Upgrading tvOS versions can reset the privacy permissions back to the default (more restrictive) setting.Apple released tvOS 17 on September 18.

  • Uninstalling / reinstalling Zwift is a quick and effective way to see the prompt to allow Bluetooth permissions agaiin.
  • Another way to do it is in tvOS settings. See Apple’s Support page for the how-to.
1 Like

Had the same, updated specially before the DRS-race. Had several drop-outs and a final dropout 10sec for start. Also stages sb20, and Zwift play on ATV.

Had to pull the power of ATV and finally it seems that the connections was stable… :confused:

On Monday while doing a group recovery workout my Atv… Kickr V5 (direct connect) totally lost power and cadence after about 10 mins, leaving me with a mad scramble to get into the menu and repair via Bluetooth as dircon wouldn’t respond to pedal input.

A mad FTP level chase for 5 mins to catch the group blew the recovery part of the session away :rofl: