Game Update 1.46 [August 2023]

Had the update this morning and it crashed at the pairing screen or just after, I wasn’t in the room but zwift had closed itself down and when reopening it the pairing screen wasn’t showing anything, had to reboot the machine to get it working, might have been a one off mind as after the reboot everything was fine

1 Like

Hi Anne-Claire, welcome to the forums!

I don’t know if this has been said before, but there’s been something wrong on ATV on the ride summary since an update (don’t remember which one but was near mid-July). When you click on the timeline tab (or the power related one), then you can’t go down on the screen to click on « OK ». To get out of the screen you have to go back to the general tab and then scroll back until you can reach the « OK » button. It can be really annoying.

Several users flagged this up about a month ago, and @Rowdy kindly promised to flag this up to Zwift staff. Unfortunately I haven’t heard anything since, and the problem is still there and really annoying.

Any news @Rowdy ?

Any chance this update could cause Apple TV to continually put up a “ pairing request” four and HRM and not allow you to connect because the pairing request keeps coming back up even after you cancel? This just started today.

Rich, this is what happened to me during a coffee break. It crashed, and then I couldn’t pair again

New update is crashing. 2x in first 30 minutes, during Sevens workout. Restarted device in between crashes.
Only other app running: settings
iPad Pro 9.7 inch
iPad iOS 16.6
Thanks for all of your work.
Love the platform.

1 Like
2 Likes

Did the new race results screen lose your placement out of whatever number of riders there were (eg. 10th out of 20, etc), and now just shows ‘10th’ ?

1 Like

Any Update on Apple Silicon support (ie M1/M2) for MacOS?

Not directly about Apple Silicon, but there was this update about upcoming graphics profile improvements specifically on M1/M2 systems:

@shooj Is there any chance you guys might do something about the new results screen not closing itself? It’s quite an annoyance to get off the bike to close it after an event ends and you want to continue riding or join another event.

I made a separate post about it in bugs and support, you can remove that one if it’s not the right place.

A UI issue in 1.46 on the save-ride screen (this is on macOS). I can scroll the list of clubs by swiping on the trackpad. I cannot scroll the list by clicking on the scroll bar. And if I hover over the bottom club in the list which is on top of the array of photos and videos, scrolling by swiping on the track pad no longer scrolls the clubs list, it instead scrolls the photos and videos that are underneath the club I’m hovering over.

Finally, it runs natively on Apple Silicon :slight_smile:

$ file ZwiftAppSilicon
ZwiftAppSilicon: Mach-O 64-bit executable arm64
2 Likes

Thanks @Rowdy
Double-checked today while riding with Coco on the triple flat loop.
ZP controllers worked well for about 45 minutes. Got the haptic feedback disconnect on the right controller.

Again, I could still activate power-ups with the Y button. But steering did not work. I purposely drifted off the back to make sure the road was clear on either side of me. Would not steer left or right.

Long press Z button ride-on bomb also stopped working.

This right controller disconnect has happened on every ride I’ve done since the 1.46 update.

(20 Aug 9:45 PM PST/4:45 UTC) Pack Dynamics 4.1 is on for all worlds now. The RoboPacers will be using it on their restart in ~90 minutes or so.

6 Likes

I like the new race result screen more than the earlier one - good work! :+1:

The one visual improvement would be to replace 1, 2 a 3 position with :1st_place_medal:, :2nd_place_medal:, :3rd_place_medal: pictures like on the picture below.

Also, something is not accurate with the best power charts as the W/kg numbers are not matching Zwift Power numbers.

1 Like

While I can see that binary exists, what runs on my M1 is the Intel executable (ZwiftApp) using 1.46 (though I see I can run ZwiftAppSilicon manually)

Climb portal ascent time bug. Today I did 7 reps on Bealach na ba starting 2 minutes after it was released. I noted that when summiting, the time displayed on the “finish” screen is not the same time as displayed on the left hand side, i.e. where it toggles between current list of times and your own list of times, or the “PR ghost” time.

In other news, Bealach na ba is savage, in the best possible way =)

I ran it from Terminal … compared to AppleTV the graphics are much better.

1 Like

It is indeed.

One hundred percent agree. This needs to be changed, I believe you should still need to click on the option to leave the group you have chosen. It should not be so easy to accidentally leave a selected pacer group.