Game Update 1.42 [June 2023]

Since I have received these recent staggered updates towards the end of the week, does that mean I will always get these towards the end of the week?
(like Christmas has come but I have to sit 4 days on the naughty step…:wink:)

I got the first one on the last possible day and i got 1.41 on the first day and still waiting for 1.42 so think it isn’t static update to update.

1 Like

Android users please note.

It’s completely random :slight_smile:

1 Like

Me too, I was also hoping for Repack Rush to exist alongside Repack Ridge. Like partway thru you could turn right and do the Rush if you wanted, or go left to the steep climb.
Steering is weird without handlebars that don’t actually turn, but the Ridge climb was still fun.

On the other hand, teleport is here! Yay!
and I hope climb portal comes first week of July like has been speculated… nudge nudge wink wink @shooj :wink: :smile:

1 Like

A post was split to a new topic: U-turn not working after Repack Rush [1.42] [June 2023]

Will there be a way that we could just use ZC again to access steering over buying new hardware? That’d be great! I tried doing that today (because I don’t have a steering device) and would love not to have to buy separate pieces.

We’re not planning on bringing back support for the Companion app as the steering input. During early FutureWorks testing, we found that inputs from the gyroscope sensors varied from phone to phone and player to player (bike to bike, more likely) We’re sorry to disappoint if it worked well on your phone at the time, but it was an inconsistent experience overall.

That’s ok. I just didn’t know if I wanted to invest in a Sterzo but I do want to be able to some day ride ALL the roads in Watopia. Thanks for clarifying.

1 Like

You could just have left/right buttons

1 Like

Repack Rush not available on ATV this morning after updating. Teleporting is though… That is fantastic!

Anyone seeing Repack Rush on ATV?

Yes, I can see it on my ATV 4K (2021) running 1.42.0, but only if a steering device is first paired in the pairing screen.
(If you don’t have a steering device, Repack Rush will be pointless.)

BTW, I’ve experimented with un-pairing the device after having got to the ‘Explore Routes’ listing that is showing Repack Rush. This doesn’t instantaneously make Repack Rush disappear from the routes, but if I move to ‘Workouts’ and then back to ‘Explore Routes’, I can no longer see Repack Rush.


Hello Zwifters - more devices will receive the 1.42 update today.

Did you pair to a steering device before you dropped in to the Home Screen? Repack Rush won’t appear unless you did.

The game is context-aware and won’t show you options that you can’t use. Another example is the Trainer Difficulty slider - that doesn’t appear unless you’re paired to a smart trainer’s “Controllable” signal.

1 Like

I’m just wondering, in your opinion, is getting a Sterzo worth it? I just am wondering are there some flaws and do the pros overweight the cons? I would LOVE to try the new steering course!

Hi @shooj and @Jon, is there any information available on rider shadows making it to M1 Macs? I recall seeing that it was planned for after the transition to Metal which has now happened, so was hoping for some indication re: timeline.

1 Like

NYC has had the same bug for ages but it’s less extreme (in Makuri it was also there from the start but only became ridiculous with the latest expansion): Minimap magnification changes on its own

I guess this must also be “a very minor issue”.

Same “minor” issue as the delayed elevation gain in all London routes. That one bothers me even more than the giant zoom in on mini map.

I’m one of the several people who have recently re-reported a rather old bug with steering on the Kickr Bike where one gets stuck on either the left or the right edge of the lane, esp. when riding with pace partners.
Just got the 1.42 update and decided to try Repack Rush. Here’s what I saw:
Steering works well for a a minute or two (even though it’s laggy enough for the game part to be a bit frustrating), but then I got stuck on the right edge and no steering button press, hold or mash would move the bike. It does recover though! After about another minute(?), the steering buttons moved the bike again. Unfortunately shortly thereafter, I got stuck again, this time on the left edge, and nothing would get me off of it.
Seems to be very straightforward to reproduce as it happens almost immediately, but happy to help debug this further.

I didn’t pair my sterzo but will do tomorrow. Thanks