Game Update 1.21 - January 12th, 2022

New feature requests can be created here Feature Requests. I’m pretty sure you will find an existing FR for these suggestions if you do a search. Give It a vote!

I am level 1 and all my workouts are gone.
I am offered a 7 days free trial as paying member :scream:

Ever since the update (I mean, starting immediately on the ride I did after updating and launching the program) I haven’t been able to get into game mode on Companion. I can’t think of anything else that has changed with my setup aside from the update. (I did an event the day before the update and everything was fine). I’ve worked through all the basic steps to fix this – same wireless network being used by game and companion, companion (phone) is in airplane mode with BT off, I even disabled my firewall and uninstalled/reinstalled companion… anyone else having this issue?

NEVER MIND! I forgot to try the nuclear option – unplugged, waited 10 sec, then replugged my modem and router. Now it works. It makes no sense, but it works so I’m not asking any questions.

What about my computrainer not pairing after a Windows 10 update about 5 days ago. I did everything I could think of with the serial to usb driver and the only thing that fixed it was a system restore to before the Windows update. I lost a ride that night and now I’m don’t want to update Windows 10. Windows device manager showed everything as good constantly and working as normal.

This was prior to this last update by a day or two just for reference.

Reminds of the joke, “If Microsoft made a Car”. Rebooting would fix everything…

1 Like

Zwift support:
I was using the newest Zwift 1.21.0 (100317) and the app crashed on my Dell PC during a Meetup ride this morning and it did not put me back with the meetup ride, it also did not save full ride details so I could review and post.

Version

I created a meetup using the companion app using the Out and Back on the Volcano (25 miles)course.

I had one other person riding with me and they dropped off/quit around 15 miles. I continued and with about 8 miles to go the app crashed. I was able to start the app up again on my PC but it did not take me back to the location where it crashed at like it does if you are just riding a course that you pick during start up of the app.

It would be nice to be able to rejoin a meetup after the app crashes or at least at a minimum save the data from the ride so you can post.

Equipment
Trainer : Saris Magnus M2
Heart Rate / Scosche Rhythm+

Here is a screen shot of pc specs to show that it is fast enough to support app.

He is what the zwift/companion app was able to save.

Thanks… keep up all the awesome work on new courses?
Do you plan on having an interface app for rowing? I have a concept2 rower and would love to have it somehow interface with zwift.

Since the recent game update I have had problems with workouts in Meetups & Events. On 1/13/22, I signed up for VO2 40/20 at 7:00. When I joined the event, the workout was not on the left, and my avatar did not have the tablet in front of the handlebars. I was in the group, but didn’t get any resistance. I quit & tried to login & join again, but had the same problem.
Today, I joined a meetup, but had the same problem. I picked the workout, joined the event, and nothing. No workout, no tablet on my handlebars, no resistance. I then tried to leave/rejoin and I got the workout, bu wasn’t in the meetup with the rest of the participants.
Workouts from my custom folders or the list on Zwift work fine.
I use Apple TV4K.
I then tried again on my iPad & PC, and I had the same problem.

I did however find a way in which I picked the event from the Companion App after I started a ride, and that worked, but an attempt the same way earlier didn’t work.
I’ve been doing meetup workouts & event workouts for a few years & never had this problem.

Windows10 machine here. Ride froze 20min into the TdZ Alpe ride yesterday and about 10min into the ride today. I had no problems Thursday using the exact same setup.

Anyone else experiencing this?

Same same. And what’s more annoying for me is that zwift.app doesn’t use macOS keychain to supply the password and copy/paste is disabled. So if a machine generated and managed password like “N9rJzop9rB9U” isn’t something I care to remember, I now can’t use it automagically. I am going to have to rekey it each time or change it something dumb and memorable. My zwift subscription hasn’t actually started…this is the free demo week that came with my trainer. Not feeling good about paying for stuff that breaks things that were working just fine a day or so ago.

1 Like

btw, your pc specs is very weak for a good Zwift experience, it is a dell office notebook, totally unsuitable for 3d games with that intel 620 inbuild gpu… (and the cpu is slow too, only the memory amount is ok, but that is not necesarry for Zwift) Honestly, if i were zwift programmer i would ban the use with such a device, but the income and the profit are the main goal az Zwift and not the perfect user experience… (and they allow to use the app even with 3-5fps in lowest graphic profile, that is nonsense)

but You should update the intel gpu driver to the latest, usually that helps to eliminate such a freezing. (download it directly from intel website, not from the dell , those are always very old drivers, not the most up-to-date)

1 Like

That seems a bit harsh. There should be no reason why a 10th gen Intel GPU setup wouldn’t run Zwift decently, as long as you weren’t expecting high frame rates and very high resolution. It can run older 3D games fine.

If you haven’t already, then start a new thread and post up the full specs of your PC.

@Wes and still failing to reply. I wouldn’t touch any hardware from Zwift if their response is like this…

10th gen but with very slow freq and low voltage (U variant) so its performance is weak (so that it is 10th gen is not an advantage :slight_smile: ). Of course, there are older 3D engines which run much better with an intel 620 and with this cpu but not the Zwift’s own unoptimized 3D one (with massive multiplaying). This (and the IRIS too) Intel GPU is not good for Zwift and lots of freezing issues are coming from GPU overheating or GPU halting.

2 Likes

Not quite as simple as that, the generation doesn’t really mean anything by itself. CPU manufacturers make masses of different models, many of which are designed for low power generic computing in laptops and certainly not 3D graphics. On top of that you have the power configuration chosen by the laptop manufacturer to hit its target market (battery life, weight etc). The model in question isn’t bad at all based on its benchmark scores, but it could still be being heavily throttled by the config.

Anyway seeing as it’s 10th gen, it would have been useful directing the OP to that old driver workaround but it doesn’t work on Windows 11. :frowning:

New in game bike sounds?

Has the on bike ‘chain noise’ been added or increased in volume with this update? I haven’t noticed it before. I find it really unpleasant, alongside the other noises (trainer, fans and music) it just sounds like background static. I actually thought my headphones had a problem after starting this update! I like the usual background sounds and they add a lot to the game experience but with this chain noise I’m having to turn it right down or off.
I also noticed a lot of clunking sounds on the hills, are these supposed to be gear changes? Again, I hadn’t noticed these before and are also really annoying.

2 Likes

Apple 4k since update 1.21 totally unusable for me the home page is a complete mess can’t access rides or training or settings

Mess how? Can’t access as in something wrong w/remote?

Aside from having to log in again, everything works fine w/my Apple TV 4k. Is your Apple TV OS updated as well?