Game Update 1.18 - October 20th, 2021

Ah, thanks, I don’t have that issue. I don’t use bluetooth either, so perhaps that is why?

The one noted in the post that I responded to. Gradients on the screen did not match the resistance on my Kickr or Climb. In short, there was a considerable lag that was not the result of mere radio interference. For example, on the 23rd Street KOM, I was still tilted downhill and spinning at downhill RPMs for the first quarter of the climb, and, upon summitting, still had a few hundred meters of “climb” remaining, according to my Wahoo equipment. Nothing changed from my prior ride to yesterday’s, except for the new Zwift software.


Version 1.18.1 for PC and Apple TV devices has been released.



Yesterday after 1.18 update on a Mac, the ‘A’ button to open the pairing screen did not stop the avatar.
It kept moving.

After today’s update 1.18.1 when hitting ‘A’ button and opening the pairing screen stops the avatar as expected. But U turn does NOT work, either on the Zwift application nor on the Companion App.

I rode for 40Km without a single issue. I was able to select direction options without issues, and the speed of my rider seemed ok.
Then at some point I hit U button to do a U turn and it didn’t work. Tried with the keyboard, the button in the Zwift application and in the Companion App. No way to get it to work.

And after hitting the U button, everything started going wrong… Route directions were totally ignored. No matter what I select, the avatar would go wherever it wanted. The speed of my rider was totally off. I was pushing 2.7 w/kg on a -6% descent and the speed was 18 km/h… People doing 1.2 w/kg would pass my like airplanes.
Even saw a rider supertucking UP de Alpe du Zwift! He was going up without pedaling at 70 km/h on supertuck position!.

Is this a know issue?.

Yup: Can't U-Turn [October 2021] [1.18.0]

Thanks Dave!

Version 1.18.1 for Android devices has been released.

1 Like

Just finished ride up Ventoux…still can not return down hill…the turnaround function does not work just riding around Ventoux at top and not going down hill even automatically. This is the same for the last two days riding this course. Is the bug fixed?

1 Like

Doesn’t the top have a turnaround loop?

1 Like

Zwift glitching since last Win 10 update… (~9 days ago)
TL:DR - It Spotify “wot dun it !”
Anyway Storytime! - So the freeze/ glitch went to 2min intervals today, I popped up Task Manager, and on the Perfromance tab saw the cpu was spiking & gpu was dropping off, so switched to Detail tab, every glitch/ freeze was matched to a Spotify task taking extra resource, now there was nothing obviously wrong with Spotify so it looked all the world like another Zwift Bug…
A re-Boot thankfully fixed it, so probably a rogue task as Spotify didn’t apply an update.

Remember It’s not always Zwift !

Seems I’m having the “lagging resistance” issue as well on Apple TV and KICKR Bike. Rode the Surrey Hills map for at least 15-20 min before I actually felt any change in resistance, all the while I was supposed to be climbing

My frustration level with ZWIFT continues to grow. It seems with each “update” there’s just more bugs. I’d say 50% of my rides actually function properly :-1:t2:


Version 1.18.1 for iOS devices has been released.


@Zachary_Mazin may I ask on which platform you were running Zwift when you experienced your gradient lag? (Windows/Mac/Android/iPhone/iPad/Apple TV)

@John_Blumenthal I’m afraid the 1.18.1 patch does not address the “U-Turn” issue. That doesn’t mean there isn’t a plan for resolving this issue.

I think you will find you can perform a U-Turn anywhere in the game without issue, until the Zwifter makes an attempt to U-Turn exactly at the finish line of route completion. For now, please try counting to ten before U-Turning after completing a route. This should allow the U-Turn to complete normally and avoid this issue.

This issue seems related to a fix added to prevent an exploit involving U-Turns on route completion. It may be that completing a route and performing a U-Turn causes the player avatar to get stuck in a U-Turn that never starts, hence being stuck at the forced lower speed for U-Turns, and the inability to make subsequent U-Turns or choose intersection decisions.

Once the player avatar is stuck in a U-Turn, there is no way to recover the normal behavior besides shutting down and relaunching (on desktop) or force-closing and launching (on mobile).

You can also follow any developments here:

1 Like

Windows 10. Thanks Mike.

  • Fixed an issue which would sometimes cause long straight lines to appear on the map during route selection.

Sorry team, the fix didn’t work. Whatever was done, it has now caused the bug to happen for me - this is the first time I’ve even seen or had this bug, never had the straight line issue before this update.

1 Like

PC app still freezing for me after 5 mins, or less, within a course. Android app and comp app all working fine - just still seems to be issues with PC.

A post was merged into an existing topic: Hiding option for Zwifters with steering option

No issues at all here, you’ll need to give a full run down of your specs and what problems you’re experiencing if you want others to be able to offer meaningful help. :+1: