Game Update 1.18 - October 20th, 2021

Read the post that is specific to this issue.

Thx Zwift for ruining my vEveresting attempt. Did all day preps, after 1 ADZ did u-turn and the game was hoax. Unable to go faster than 24kmh… Quit. DJEEZES.

2 Likes

No sound using ATV[quote=“Wes, post:1, topic:558866, full:true”]
Hey Zwifters, we have released version 1.18 of the game client, which includes a number of new features, improvements and bug fixes.

The update is available for download now on all supported platforms (PC, Mac, Android, iOS and Apple TV).

If you are planning to join an event on your next Zwift session, please make sure you log in a few minutes early to download the update to get access to all the latest features.

New Features and Content

  • Added the Le Col Training with Legends workouts, 12 in total. These workouts will become available on November 1 2021 at 00:01am GMT.
  • Added new Workout of the Week workouts.
  • Added the Liv Langma SL Advanced Disc and Moots Vamoots RCS to the Drop Shop.

Bug Fixes and Improvements

  • Fixed an issue which would sometimes cause long straight lines to appear on the map during route selection.
  • Fixed an issue that would sometimes cause a crash when returning to the home screen after ending an activity on PC and Mac.
  • Fixed an issue which caused Zwifters to be unable to use their phone as a steering device on Repack Ridge.
  • Fixed an issue which caused dialogue to go missing on the first ride tutorial.
  • Fixed an issue where gravity would play favorites with some lucky Zwifters, giving them the power of flight. Since Zwift is not a flight simulator (yet?!), we had to put a stop to that.
  • Fixed an issue which caused a delay in the Pace Partners appearing in the home screen.
  • Fixed an issue where pedal assist would not activate when joining a Pace Partner in certain situations.
  • Fixed an issue which allowed Zwifters to do a quick u-turn on a route and get the achievement for the reverse version of their current route.
  • Fixed an issue where Bluetooth devices could not be detected for Zwifters running MacOS Monterey.

Update 1.18.1 - October 21st, 2021

We have released a small update to 1.18 to address two critical issues. This update is currently available on PC, MacOS, iOS, Android and Apple TV.

  • Fixed an issue that would cause Zwifters to continue moving while in the pairing screen when they should have been stopped automatically.
  • Fixed an issue on MacOS which would cause large black boxes and other visual anomalies to appear on screen.

If you encounter anything unusual with this update, please post in the thread below.

See you in Watopia, Ride On! :ride_on:
[/quote]

If you believe that Zwift’s HR measurement is wrong, just try recording it with another device (e.g. your watch or a Garmin/Wahoo/etc) and compare.

Lots of people already do that (check dual records in the Analysis tab of any big race in Zwiftpower). I haven’t found any HR discrepancies there so far.

1 Like

I am having huge problems logging into my account via Apple TV

When entering my details ( user name / password ) with the remote it returns to the log in screen when I use the down key. This is always on the second press. It is randomly placing * in both the user name and password box. It also does this when I try to use the auto populate function for my email

Re-installed Apple TV and Zwift and still have the same issues…remote works perfect with other apps.

Zwift ver 1.18.1 ( 85684 )
Apple TV OS 15.0 ( 19J346 )
The model is A1625

Thanks

2 posts were merged into an existing topic: Route selection scroll bar missing on Windows [October 2021] [1.18.0]

Today in Zwift Bugs: everyone else in world keeps blipping in and out, including the pace partner I wanted to hop on with. I caught CC and then she was gone and suddenly 30 seconds ahead of me as if the draft was on another plane of existence.

That sounds like you were having an internet connection issue.

2 Likes

I went back two releases on my Kickr Core. ITs working perfectly now.

1 Like

After update, ive got approx 20 more FPS but all riders, including myself blinks/flashes stochastically.
Run on Windows pc 1080 resolution.
No issues using android

Only me?

This is because you’re now using the latest launcher/installer. See this workaround: New launcher (1.0.51) causing stutter on Windows systems - #49 by Dave_ZPCMR

My Zwift cant connect (my phone bluetoorh) to my Magene bike trainer after last update. anyone can help me?

They will probably need more info about the set up you are using.

Noticed tonight that the Back button on the pause screen has a massive white box around it when you hover over it with the mouse. This is on PC, and no other button reacts like this (like normal). If I had to guess, I’d say I’m seeing part of an exaggerated interface intended for Apple TV. This unexpected and presumably unintended crossover may be the reason for some other weird UI things, like the missing scroll bar.

vid

Streamable Video

1 Like

Using Android v11 with a Wahoo Kickr af18: updated to the latest 10/22 version through the Play store.

I can no longer connect to any device via Bluetooth. It won’t find my trainer, cadence sensors or wahoo HR monitor.
(I know everything works just fine because my bf runs the same equipment on his iPhone)

Will there be a patch released? I tried uninstalling everything, uninstalling just the update - but it won’t find anything via Bluetooth through the Zwift app.

1 Like

I had this same issue last night on Android. Running Zwift on my new Samsung 21 Ultra, which has been running Zwift without issue for a month until the update. Did the Mountain Route for the first time, and Zwift crashed on saving so hard that my phone rebooted. When I got Zwift running again, it offered to resume my route, which was about 1km short of where I had stopped before. Without moving, the Route Report showed I had ridden the entire course, so I saved the resumed ride without moving. I had taken a screenshot of the “route completed” banner using my phone itself (since the Android client won’t let you use Zwift for a screenshot of route completed or level level/item unlock banners). I re-entered the game, and Mountain Route was now checked off as being done. I checked the experience points gained, those calculated out correctly (I keep a log of xp and Drops gained each ride). But instead of the 43,000+ Drops gain shown on my route banner screenshot, I got 197 Drops. Not 1,970. Not 19,700. Just 197. Incredibly frustrating.

The night before, I was unable to complete the Innsbrukring with about 1km left because Zwift suddenly lost the ability to see my trainer in Bluetooth. I’d reconnect using Zwift, but it would only stay connected for several seconds, then lose connection again. That was immediately after I had completed the Dempsey Challenge, which I attempted to ride out to a full kilometer after the finish line for the 20xp, but the Bluetooth connection failed then too, and I could not keep it connected. I rebooted and reconnected my phone before doing the Innsbrukring, thinking it may be a hardware issues (odd that an issue would crop up after a month of perfect connections, but you never know). But Zwift lost the Bluetooth connection again. I tried connecting other Bluetooth devices, which worked without a problem. Another issue that literally never had happened until this update. I’ve been updating Zwift, and believe both of these happened using version 1.18.1.

Updated my ATV after asking some club friends if they had any issues. They said all was okay so I updated.

• No spanner in the pairing screen to let me calibrate.
• No ability to choose a world in which to ride.
• No in-ride join event button bottom left, only the timer and description of the event.
• No rider names in right-hand list as if no internet but rider names were attached to riders.
• Pause Menu was only half visible with 50% off the screen. The pairing button was okay visible but half the button missing.

Normally I seem to avoid most of the bugs but not this time!

On the bright side I could U-turn.

In latest update, while In watopia, am unable to make a u turn. Once I hit the uturn button on screen, avatar doesn’t turn and then bike speed will not go above 15 mph no matter how hard I pedal.

For now i am gonna ride with Bkool and wait when Zwift is fixed.