Game Update 1.15 - July 19th, 2021

Poor update. Zwift doesn’t start, no matter a restart or reinstallation.

Please fix!

1 Like

The app store eventually let me download the new version. I suspect demand is high tonight.

What are ‘automatic screenshots’?

Sidenote - I’ve been having an issue where after a while in the same biking session (like after 20-25 screenshots), it stops saving the ‘clean’ versions and only saves the full version with hud.

I have been only doing workouts lately and I noticed this post mentions workouts, so is this what got fixed? I use the companion app to take screenshots, Zwift runs in my PC (Windows 10)

Yeah, mine eventually found it as well. :slight_smile:

I’m facing the same issue as well.

Updated on Apple TV. Completed two activities, Makuri Island and rolled into TFC Mad Monday race. Garmin and Strava think they are only one event. Does not upload the second longer (40.1 km) ride. Download fit file from Zwift and upload to Garmin thinks the activity is already uploaded on Garmin as the Makuri Island activity. Help!

1 Like

My Zwift crashes upon loading after this update today. It goes to the blue loading screen, then the cursor turns rainbow and a popup appears “Unexpected Error”:

I’m on MacOS 11.4 (Big Sur). I tried rebooting the laptop a few times, and that didn’t help.

1 Like

Sorry Wes, but the improvements to pack diyamic didn’t look good. The avatar is doing zig zag on the road, this makes me nauseous and makes me not aware of distance from the user in front of me. It gets very confused on the screen. Thanks for the new routes and other improvements


I had exactly the same this morning it saved however no file was sent to training peaks or strava and there is only limited information on the companion app.


The overtaking of other avatars just out on the road has gone crazy too. Often I was going over the centre line nearly bumping into oncoming traffic on Makuri island. It could be possible for head on collisions with the right timing:)

1 Like

I tried again later and did a short 3km ride. This time I stopped the ride through the Apple TV app rather than companion app.

You having same issue means something is going wrong.

1 Like

Yes, it’s the same here for me. I can only “cure” this by back grading my Wahoo software. Is this a Zwift or a Wahoo issue….I’m not overly tech. competent

Uncommanded swerving for all riders in a meetup this morning after update. Greater London​:hot_face::hot_face::hot_face:

1 Like

Whenever there’s an update which changes drafting, pack dynamics or rider interaction, I feel like it’s probably to be expected that weird stuff happens until the majority of users are on the latest version of the game. Everyone on platforms other than PC and Mac has the potential to be on an outdated version. That’s a lot of people.


Heads up to Event Organisers that the Flatlands Loop on Makuri Island now takes a slight shortcut through the top town (now takes in the sprint). Those (on iOS) who have not yet updated still take the old slightly longer route around the outside of the town and have to chase back on to the group when the roads come back together as you exit the town. As this is a fast descent it isn’t easy for them to get back. It might be worth considering steering clear of using this course for group rides for a few days until more have updated.


Still no solution for the Sterzo smart problem??
I have updated it and still Zwift gives error saying I have to update it since last previous update.
Please give me a solution for that as well….

  • 1 for this

Same, just finished the classics race in Eastern AU C2, zwift saved a file of 6km that said I did 1km. Didnt save correctly, apple tv using latest update.

1 Like

New update, new problem. When external powermeter is connected as a power source, connecting trainer as controllable is impossible. Checked with Ipad air, Iphone, Xiaomi Mi 9T Pro and Powerbox, 4iiii, Ronde, Assioma. Really?


We had drop outs, and on this regular group ride ( AHDRL) as a group we were “all over the place”- not sticking together properly and veering around . A few couldn’t upload their rides. My avatar just stopped- despite a max wifi signal. The group would vanish, then my avatar would sit up like loosing the draft, then everyone reappears again and my avatar goes back into draft mode.

1 Like